Automobilista Awesome Mod - The Audi R8 LMS GT3 with Paul Jeffrey
Available now on the LIVESTREAM page.

PLZ HELP F1 2010 Executable has stopped working

Discussion in 'F1 2010 - The Game' started by Nick Clyne, Feb 24, 2011.

  1. Nick Clyne

    Nick Clyne

    Hi guys,

    after playing the game for a while now on PS3 I decided I wanted to get the game for PC. After installing it I get the message "F1 2010 Executable has stopped working" and then I can choose either "close the program" or Try to find a solution

    I'm running Windows 7 64 bit
    My system is a Dell 1555 Notebook

    Intel (R) Core 2 Duo CPU T6600 2.20GHz
    4Gig RAM
    ATI Radeon Mobility HD 4570 512Mb

    I live in Dubai, UAE where I do not believe GFWL is actually supported (on the website's countries list) but I don't know if that matters. Surely that wouldn't be why I'm getting the error message that I am getting.

    Below are details of the error message.

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: F1_2010_game.exe
    Application Version:
    Application Timestamp: 4c766231
    Fault Module Name: ntdll.dll
    Fault Module Version: 6.1.7600.16695
    Fault Module Timestamp: 4cc7ab86
    Exception Code: c0000005
    Exception Offset: 00038db9
    OS Version: 6.1.7600.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    ANY help at all will be much appreciated

  2. Paul Lock

    Paul Lock

    Seen another problem like this on here but nothing I suggested helped. Ive spent a bit of time digging around....

    A similar problem is mentioned on the Codies forum regarding faulty ntdll.dll , and the advice from Codies was that single core processors are not supported.
    Yes I see that you are running a Core 2 Duo, so It may be worth checking in your bios that (depending on the version) -

    1 - you have 'single processor mode' DISABLED
    2 - you have hyperthreading ENABLED.

    You may have one or both of these options available in your bios, or maybe something different again, but just make sure it looks like your dual cores / HT are up and running.

    If you do notice something needed tweaking in the bios and the game still doesnt load, uninstall and reinstall F1 and try it again.

    Interested to know what happens so do post back with results.
  3. Nick Clyne

    Nick Clyne

    Hey Paul,

    thanks so much for your ideas. It seems that those options weren't available in my BIOS. In the device manager it looks as though "both" processors are running as normal.
    I installed the game on my mate's Dell - i5 processor and it worked just fine. WTF? So I guess it's a problem with my system. I'm tempted to invest in custom built desktop machine. Seems a bit excessive just to solve this problem, but it'd be great all the same. Oh well... still not sure what it is that my computer doesn't have or what it is that's blocking my fun.. cheers
  4. Paul Lock

    Paul Lock

    I think windows will always see it as a dual core chip, but whether its running in single/multi core/HT mode depends on the bios settings.
    Can you refer to your motherboard manual and see all the options available to you? Some can be hidden away somewhat.
    I have never owned a core2 so unfortunately I cant draw from experience, but I do know that I have similar options for my i7.
    Maybe you should see if there is an update available for your bios.

    The only other suggestion is that your ntdll.dll has become corrupted in some way, and either repairing or reinstalling your o/s could be an option.

    Good luck and let us know how it goes.
  5. Nick Clyne

    Nick Clyne

    Hey, I ended up totally wiping my laptop and starting afresh. Installed it again and it seems to be working fine. Not a lot of insight as to what was really preventing it from working though, but I'm happy.
    Only getting 20 fps on my laptop - playable though. Are there any 'must have' mods that I should get?
  6. Scott Webber

    Scott Webber

    I always get the message everytime i click on the game, just keep closing the box and clickin on the game it will start up.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.