PCARS2 VR settings

Norseman

75RPM
Original poster
Mar 13, 2009
93
23
Hey guys,

Quick question on tweaking the settings in Project CARS 2 for VR... I recently picked up a Samsung Odyssey +, and have been amazed with how good PCARS2 looks in VR, but I have this annoying problem with pop-up track objects and parts of cars disappearing & reappearing. I'm not as familiar with PCARS2 as I am other sims, so what settings should I play with to fix this?
 

Sonoafafayon

100RPM
Mar 15, 2017
161
165
Sounds like it's either the LOD's or occlusion culling. Maybe increase the sections loaded (can't remember the exact name) so that more of the track is loaded before you get to it.
 

Norseman

75RPM
Original poster
Mar 13, 2009
93
23
Thank you Sonoafafayon for your input. I'm still trying to figure out where that last suggestion (occlusion culling) is though... are you saying it's in Nvidia settings or somewhere in the game?

Btw, I should've probably listed my specs, and then maybe more people will offer suggestions:
Asus Maximus VIII Gene motherboard
Intel i5 6600 (overclocked 23%)
Corsair H100 V2 water Cooler
16GB ram (G.Skill TridentZ DDR4 3200)
Asus RTX 2080 ROG Stryx video card
Corsair LE SSD 240GB (2X)
Windows 10 64bit Home edition
Thermaltake Core V21 case
 

Sonoafafayon

100RPM
Mar 15, 2017
161
165
Ah no, the occlusion culling would be an issue on their end, it's something you bake when making the game itself. Do you notice objects disappear in the sides of your vision, like when going out of shot, or when they're right in front of you?
 

hotak

100RPM
Sep 17, 2008
163
103
32
you could try to either increase the track detail to increase the rendering distance, or play with the "near clip plane" setting if the problem is with near objects
 

Norseman

75RPM
Original poster
Mar 13, 2009
93
23
Ah no, the occlusion culling would be an issue on their end, it's something you bake when making the game itself. Do you notice objects disappear in the sides of your vision, like when going out of shot, or when they're right in front of you?
All is in front of me. Nothing noticed along side.
 

Norseman

75RPM
Original poster
Mar 13, 2009
93
23
I've played with that a little bit, but not a lot hotak, so maybe I play with those settings Al title more.
 

Norseman

75RPM
Original poster
Mar 13, 2009
93
23
I found the following settings in the Steam forum that was referred to as "Pcars2 VR Perfect Graphics guide for nvidia 1080", and it really did the trick, as I no longer am seeing the track pop-ups. Here's what was in the guide (for the last 2, I used openVR configs instead if occulus):
Virtual Reality:
----------------

Super Sampling (Pixel Density): 1.5

Performance:
------------

Resolution: 1250x720p (lowest possible res but still read able text,
its only impact on menue quality but saves fps when driving without quality loss,
so get more fps -novrmirror or lower resolution but not possible to read text anymore
in main menue)

Window: Yes
Texture Resolution: High
Texture Filterung: Anisotropic 8x
V-Sync: No
MSAA: Medium
Post AA: OFF
SS: Off
Reflection: Low
Environment Map: Medium
Car Detail: High
Track Detail: Medium
Pit Crew Detail: Player Only
Shadow Detail: Ultra (low impact on fps, and fixed flickering shadows)
Enhanced Mirror: No
Motion Blur: Off
Render Frames Ahead: 1
Detailed Grass: Off
Particle Level: Low
Particle Density: Low

Visual FX:
----------

Post-Processing Filters: Off
Exterior Sun Flare: Off
Interior Sun Flare: Off
Bloom: Off
Heat Haze: Off
Exposure Compensation: (default)
Rain Drops: Yes
Vignette: No
Crepuscular Rays: No
Screen Dirt: No
Cockpit Mirrors: On


New Filter Distance Tweaks, removes Blur:
-----------------------
Open graphicsconfigoculusdx11.xml in Documents\Project CARS 2
<prop name="SharpeningStrength" sharpeningstrength="0.720000" />
<prop name="SharpeningClamp" sharpeningclamp="0.050000" />
<prop name="OffsetBias" offsetbias="1.000000" />



Open oculussettings.xml with notepad in Documents\Project CARS 2:
<prop name="NearZ" data="0.04" /> <-this is the camera near clip plane value that you can adjust inside the game
<prop name="exposureFOV" data="110" />
<prop name="EyeOffsetY" data="0.02 /> <- not sure if the deafault 0.03 is better than this, but you can adjust accordgingly
<prop name="EyeOffsetZ" data="-0.07" />
 
  • Like
Reactions: Crilin