Oculus Rift Audio not starting by default

Discussion in 'Assetto Corsa' started by Scott Barton, Jul 6, 2018.

  1. Scott Barton

    Scott Barton

    Messages:
    17
    Ratings:
    +34
    When I start Assetto Corsa the sound defaults to my speakers if I try to switch audio when the game is running it still just does speakers. I have to close AC, switch my PC audio to use Rift Headset, start AC, wait for it to load, and then switch it back to speakers so that my Buttkicker will work. I can then hear the audio on both my Rift headset and my PC speakers (and Buttkicker works).

    How do I get AC to use my Rift Headset by default instead of my PC speakers?

    In iRacing, when I start, it switches to Rift Audio and because I have audio mirroring turned on in Oculus, I also hear it on my PC speakers so my Buttkicker works. I don't have to manually switch anything.

    Thanks!

    Scott
     
  2. Jack Vos

    Jack Vos
    Premium

    Messages:
    141
    Ratings:
    +48
    C:Users/"Your username"/Documents/Assetto Corsa/cfg/oculus.ini

    [SETTINGS]
    AUTOSELECT_RIFT_AUDIO_DEVICE=1
     
  3. MarkLenders

    MarkLenders

    Messages:
    12
    Ratings:
    +19
    If this doesn't work (as in my case) go to: control panel -> audio
    right click on rift headphones and set them as "default audio device".
    This is the only way for me to make working audio from rift
     
  4. Scott Barton

    Scott Barton

    Messages:
    17
    Ratings:
    +34
    This worked, thanks!
     
    • Like Like x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.