Oculus & Pcars2 broken

roadyroad

250RPM
Original poster
Dec 7, 2013
410
254
42
It's been some time I haven't been using VR on Pcars2 (and in general) and I wanted to give it a go today, as it used to be my favourite VR experience. I had to update the Oculus software and to reset all the parameters (it was atrocious to do it, I've never struggle before in previous versions).

So I've seen that you don't need to launch Steam VR anymore with Oculus. Great news.
Assetto Corsa, Raceroom, and PCars1 work fine (I was amazed by the performance on AC and PCars1, better than before).

But Pcars2, wow, what an absolute mess it is! The game could not be launched from Steam or the Oculus app 2 times out of 3 (black screen), and each time I had to quit the Oculus app before relaunching the game, otherwise it would not even try to launch.

When it worked the perfomance was atrocious, I had to reset all my graphic settings to make it work, and even then, micro stutters (when touching a wall for example) and I got a black screen inside my headseat during practice and had to quit the session to get the image back.

And after a while, launching and quiting the game to find the right parameters for VR, the game just decided it wouldn't work anymore. I launch the game, get a black screen and... nothing more.

Anyone has the same issue? I've read on Steam that a few experience the issue. Maybe someone there has a solultion...
 

Sonoafafayon

100RPM
Mar 15, 2017
161
165
Yep, I had the launch issue just like yourself, it came completely out of the blue.

Pop this into your launch options for PC2 on Steam, should fix it no problem
-windowed -borderless
 

hotak

100RPM
Sep 17, 2008
163
103
32
I had a similar problem about a month ago with the oculus update, solved it removing the options i set on oculus app (run as admin and win8 compatibility mode) and it now works as it should.
I'd still like to find out how to make it work without opening the oculus app, since it's heavy on the hardware with no real reason for it to be (i suspect it renders the oculus home 3d menù all the time, even when in background, because devlopers are idiots and don't want it to have to be reloaded everytime you switch to it.

EDIT: anyway the problem lies in the horrible oculus app, or at least it was there for me, if not, try to do a clean pcars2 install, since it works flawless for me, and used to even with my old i5 2500k+gtx680 PC (now R5 2600X + gtx980Ti)