RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Non-FPS related stuttering (maybe swapping?)

Anyone else experience that AC can run fine for anything from 30 minutes to one hour - and then suddenly start to freeze up every other second. Sometimes it can be around 10 seconds between them - often much shorter. A lot of HD activity seems to trigger it, but after a while it settles down, but the freezing continues. Usully a reboot is required. I have a i5 3,4ghz and 16 gigs of RAM, so can't really imagine that to be the problem. But it does behave like hard drive lag, at least when it starts.

First though it was the antivirus that was effing around, but the hard drive activity does go down quite fast.

I usually have decent FPS. Drops to around 50 at worst, but I run it at 2560x1440 on a GTX660 (Asus with DirectCU2 cooling) so that's maybe to be expected. When it gets bad it SOMETIMES drops to 40 fps - as if someone pour syrup in it. Sometimes the average FPS keeps around Vsync'ed 60 fps.
Tried 1920x1080 and the behaviour is the same.

Is the game known to have issues like this? I see that others have problems with uneven FPS, but this seems more like something "breaks" in the memory management?

I can run games like BF3, that I think is quite a bit more demanding on the system then AC, and it will run perfect for hours untill I get boored :p
Have you solved your problem in the meantime?
No still get it from time to time. Like tonight. Played for hours yesterday without problem. Today - impossible. Played for a while, when suddenly it started. I just turned off the restore function on my C drive (an SSD) thinking AC might be swapping to Windows standard temp folder and Windows might be doing some kind of backing up. But no fix. I have nothing of that kind enabled on my D drive where AC lives (a 1 TB WD Green). Checked the drive with WD's S.M.A.R.T diagnostics with no errors. Have tried to disable Avast with no difference.

Not sure if it's my computer or AC. But as I said - I tried som BF3. And it's actually running really slow in 2560 with my poor GTX660. I would think taxing the card that hard would show any system glitches. But nothing of the kind exept a steady low FPS.

I rebooted the computer 3 times today - still locking up every 5-10 seconds.

Bram - have you experienced something similair?
Never :p But isn't that feature supported and automated by default in Windows 7/the SATA controller? I think that that was the reason you really couldn't run SSD's in RAID config in the beginning - the controllers/Windows didn't support TRIM then.

CrystalDisk said the SSD had about 80% life left. But the only issue where relocated sectors, which I belive is "normal"
This is pissing me off. I checked stuff out. CPU temps are around 35-40 degrees C. GPU maxes out at 68 degrees. 16 gigs of ram should be enough. Effing games just starts lagging after *random* time have elapsed. Can drive for hours. Can start from cold boot.
This is pissing me off. I checked stuff out. CPU temps are around 35-40 degrees C. GPU maxes out at 68 degrees. 16 gigs of ram should be enough. Effing games just starts lagging after *random* time have elapsed. Can drive for hours. Can start from cold boot.
Have a very similar problem which only started bout 3 weeks ago, freezes on average once per lap sometimes for a second other times long enough to crash. I have a AMD 4130 quad core processor, 16 GB ram, NVIDIA GeForce GTX 760. I was running at 60 to 70 FPS but turned it down to 45 to see if this helped. It didn't, turned resolution down on my screens, no change, turned everything down to minimum on assetto corsa and anything that could be run without off, no change. Like you i also run the game on a seperate SSD, its the only thing on the drive and takes up approx 50% of the memory. Doing my crust in as well. I tried stupid things in vain but nothing seems to make he slightest bit of difference. I also use AVAST don't know if that is interfering at all, but i do turn it off every time i race.
Since you have 16gb's of ram try to disable the pagefile on your HD and SSD and see how it goes.
I also have an SSD (AC installed on HDD) and have moved the temp/tmp folders to my HDD but I got no shuttering (over 2 hours of playing AC).

Make sure you disable scheduled scans or other programs that can cause activity on the drive while gaming. Other than that it could be related to GPU VRAM, check to see if AC is maxing it out.
Mikey Mike: I have the OS on an SSD, the game is on my D drive (a WD Green 1 tb). On my computer, it continues to lag, not just once per lap. It goes on and on and on :D

Tasos: I actually have the page file disabled. Didn't remember that I did that but.. I did. My card "only" have 2 gigs of RAM so I thought of that. But it happens in different resolutions, and if it where the VRAM, restaring the program would do it right? Or are the VRAM handled like normal ram as in that stuff is kept there "just in case" and it actually keeps the Asseto Corsas textures etc in the memory until somethin els requiers the space?
Yeah I think VRAM acts like RAM in general but for graphic related stuff, like textures. So if it's trying to ask for more while your card has run out stuttering is to be expected. Download MSI Afterburner or Evga Precision and monitor the VRAM usage. The higher the resolution the more VRAM is needed. Same goes with anti-aliasing, texture quality, etc.


Just as something to try, uninstall (not just hide) all apps; depending how they're written they might still be running while hidden.
I have a similar problem, I drive with 60fps and suddenly it is stuttering. I close AC, start AC again, a new race and everything is ok. It happen from time to time, cant tell when, but the problem was also before I installed any app.
My specs are:
Win7 HP SP1
I5-2500k 3,3Ghz
NVidia GTX 760
Samsung SSD 500GB
Run a defragmentation check on your disks. It will take a while until it finishes, but is worth. Helps with disk usage.

In game, put reflections to low-static. Don't worry, it still looks good and natural. Smoke turn off or very low. Don't use motion blur, and if you're using pp effects, no point using high/ultra settings, leave at normal or lower.

Is your cpu frequency all the time at 100%, or lowers? In BIOS disable EIST (intel speedstep).
From what I understand this is all due to some problems with code in AC. One of the devs mentioned that he noticed the GPU was getting tons of useless instructions from time to time, and that after he fixed it, the stuttering went away. These revisions are going to be released with the 1.1 update.

I really hope that they found the causes because I also get some bad stuttering from time to time. So my humble suggestion is to first uninstall any apps you may have added and see the result with default content. And if that doesn't fix it, like it didn't for me, just sit back and wait for V1.1 to be released.
Defrag is not necessary for a SSD.
I had run always a ramdisc, now I use regular tempfiles and try it out.
If I do a back view by driving, I see also weird shaders behind the car. In my Video Properties are everything on Ultra or very high, maybe a patch is already in work for that problem, I will see on V1.1 :)
Thank god that I'm not alone - allthough sad for you guys who's also affected :p Better stop beating my keyboard in furious nerd rage and wait for 1.1... :p
Not alone skagers, I'm doing everything suggested, im much better after Radu suggestions, but still get a 95% thing, and stuttering, I can only run 10 cars, low smoke etc
I have a i5 4890?k, at 3.5 MHz, but my computer shop buddy tells me it's vram, I gave a gtx970 4gb, which, actually has 3.5gb, and an extra .5 GB, apparently it's trying to use the .5 vram, after search it's a Nvidea fault.new drivers seems to have solved mist of it, hoping the 1.1 fixes the rest :(
I solved one Problem for the stuttering. I noticed in Video Options under Reflection, that when I set the "Reflection Quality" on high, the slider from "Reflection Rendering Frequency" moves to "static".
Do I set "Reflection Rendering Frequency" from static to high, very high or ultra, I get that stuttering.
Is there maybe a reason for, that when I set "Reflection Quality" to high, the slider "Reflection Rendering Frequency" moves to static?