No sound in cockpit

Jpanzer

25RPM
Old vet with GTR2, but a newbie in GT Legends. Got in installed, looks great, but no sound in the car when doing practice laps. I can hear the other cars start off, and when other cars are near on track I can hear their engines, but its completely silent in my car. I've checked audio settings, and all looks normal, but surely I must be overlooking a setting somewhere, as all else seems as it should be. Any ideas?
 

gwaldock

250RPM
Have you tried the original cars? This happens with add-on cars when the sounds are missing or placed in a folder other than "GameData\Sounds\Cars"...
 
Last edited:

Jpanzer

25RPM
Tried in both the Ford GT 40 and the Porsche 906. No sound in either. This is basically a clean install, just added a few tracks, a Gulf racing skin for the GT40, and the Le Mans Classic mod cars. It's very peculiar....
 

gwaldock

250RPM
I suggest you open one the vehicles' "Car" file with something like Notepad, see what sound file it points to and then open that file to verify it points to GameData\Sounds\. My GT40 uses \GT Legends\GameData\Teams\GTC-65\Ford GT40\panterasounds.aud, which points to \GT Legends\GameData\Sounds\Cars\
 

Jpanzer

25RPM
Jon c , it was not, but I changed it to XP compatible and it made no difference. gwaldock, as far as I can tell, the sound file points to the same path you outlined above. All other sounds work in the game except those that relate to whatever car you are driving, though oddly when in the garage and looking at the in game monitor choosing the sound button on the monitor controls does nothing. Would applying the GT Legends 1.1 patch be any help here?
 

gwaldock

250RPM
Is yours a "Steam" installation? I hear the sounds can be buggy in some Steam installations; particularly if you set it up in a custom directory instead of following defaults. I think the Steam version is 1.1...
 

Jpanzer

25RPM
Nope. It's a disc version. Bought it in combo with GTR2 many years back. Never tried GT Legends back then, but after getting back into racing sims recently and seeing how well they had both have stood the test of time, I decided to install it and give it a go. It's a shame I've had no luck sorting this, as it seems a fine sim otherwise.
I'm torn between deleting and reinstalling it at this point to see if that fixes the sound bug or just creating a second install of GTR2 and using it to run Power and Glory as a stand alone. It seems you can set up the car with greater detail in GTR2 than you can in GT Legends, so maybe that's the way to go at this point, I don't really know...
 

Jpanzer

25RPM
Jon c, thanks for the heads up. Read the thread you linked too, checked the files mentioned. They are all named correctly.
Still cant figure this problem out....
 

GTR233

500RPM
What is your os ? Due to starforce disc protection which is no more supported, you won't be able to make the dvd version of GT Legends work 100% with new modern OS such as win7/8/10. The easiest solution is to run steam version : just enter your dvd serial in steam code to get a free steam digital copy.
 

gwaldock

250RPM
I totally agree with GTR233 (it costs only $7.99 if you don't have a code) but follow setup's default settings; especially if you already have Steam installed.
 
Top Bottom