RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

New VR user, sessions won't load sequentially

Frizbe

Premium
Just got my Reverb G2, first time using a VR headset on my PC, I think I have it setup ok finally with in game settings to get 90 fps but when trying to adjust these settings I've found that I can launch a race or practice or any other session type from Content Manager but if I quit the session it will say Race Cancelled on the ending page with no lap times shown. If I try to launch a new session right after while the monitor shows "initializing" in the corner the game will exit from Steam VR and show Race Canceled without ever launching into the session.

I've updated drivers, tried different CSP versions (1.60, 1.66, 1.68) removed SOL and tried using different car and track combinations, doesn't seem to make a difference. If I set the headset off to the side so Steam VR goes to sleep and launch a session using the monitor then exit and launch a session in VR it works but that is clumsy especially since with AC I personally change cars and tracks quite often when playing. Has anyone seen anything like this or have any ideas I can try that hopefully don't include removing CM?


Oh yeah I forgot, when i first got the headset setup and working the FPS was locked at 45 no matter what settings I changed, so I started disabling CSP extras and that caused the game to crash and save a crash log, reinstalling my CPS version fixed that but now I'm stuck with having to launch non-vr in between VR sessions which I'd like to fix, the logs don't show anything that I can identify as an issue but I'm not totally sure what to look for exactly.
 
Last edited:
Sorry I can't help with your issue, but while VR only works in-game (ie CM or vanilla AC launcher only work on your monitor) I've not struck the issue you describe in over 600hrs of VR use in the game (SteamVR with Vive Pro). My point is it does work and is worth finding out what the issue is.

Try this guide (from Andrew_WOT) for fine tuning your settings.

 

Frizbe

Premium
Sorry I can't help with your issue, but while VR only works in-game (ie CM or vanilla AC launcher only work on your monitor) I've not struck the issue you describe in over 600hrs of VR use in the game (SteamVR with Vive Pro). My point is it does work and is worth finding out what the issue is.

Try this guide (from Andrew_WOT) for fine tuning your settings.

Thanks for that, I hadn't found that yet so that is a good starting point for the settings for sure.

Make sure DXGI is disabled.
So disabling that allowed me to run multiple practice sessions in a row finally, though as soon as I tried a race the same thing starting happening again and now continues with practice sessions, I feel like it's something with how the races are handling being closed early or the AI but I have a feeling deleting everything and reinstalling is going to be my next step.
 
if you are using SteamVR, you need to close it every time you exit a race. Otherwise you'll get the Race Cancelled error
 
It's a dirty fix, but after spending a few hours trying to come up with a solution, this is the only thing I've found that consistently works. It's worth a try anyway

There is something else going on, I've not heard of anyone having to shut SteamVR down after a race and in hundreds of hours of VR use I've not had this happen either. I'd suggest getting someone to look at your crash report logs (user/documents/assetto corsa/logs) to see where the issue may lie.
 
Last edited:
It's a dirty fix, but after spending a few hours trying to come up with a solution, this is the only thing I've found that consistently works. It's worth a try anyway

Same issue here for me and others with vr in my group. It's every 2 new sessions. On the 3rd session, you get race cancelled. Close and restart steamVR and it's fine again for 2 more sessions. I've learned to live with it.
 

Frizbe

Premium
There is something else going on, I've not heard of anyone having to shut SteamVR down after a race and in hundreds of hours of VR use I've not had this happen either. I'd suggest getting someone to look at your crash report logs (user/documents/assetto corsa/logs) to see where the issue may lie.
I've gone through my logs and can't find any crash reports, the normal logs show things like normal, the only stand out that it logs a pretty large number of resolutions and refresh rates before mentioning "
Could not initialize DirectX11 subsystem, trying safe mode with desktop res 3440 1440
WM_SIZE 3440 1440" and then continuing on until it finds a display mode and loads the rest of everything and works ok.

At the very least I'm glad to hear I'm not the only one having these issues, I did try verifying the files in Steam then reinstalling CSP which didn't make a difference in the end. Guess I'll keep hunting for a permanent resolution later.
 

Andrew_WOT

Premium
Are you using CM, try to go to Content Manager/Appearance and Disable hardware acceleration for UI.

1609114429759.png
 
Top