Upcoming Events

AC events on Simracing.GP ACC events on Simracing.GP R3E events on Simracing.GP Weekly rFactor 2 events

What racing gear do you use while sim racing?

  • Gloves

    Votes: 259 19.3%
  • Boots

    Votes: 60 4.5%
  • Gloves + Boots

    Votes: 130 9.7%
  • None

    Votes: 892 66.5%

New Heusinkveld Sprints not working with Thrustmaster TX wheel - Games won't load

Messages
2
Points
1
I've just got my new Heusinkveld Sprints to replace my Thrustmaster TX pedals. They assembled easily and calibrated in Smart Control just fine, all looks good but now none of my racing games will start. Everything just hangs at the loading screen (AMS 2, Raceroom, ACC, Dirt Rally 2).

I've narrowed it down to a problem between my Thrustmaster TX wheel and the Sprints. If I disconnect either one of them, stuff loads. As soon as I plug whichever back in, stuff just freezes. Non racing games seem fine although I've not tried many. Everything is fine if I go back to the Thrustmaster pedals (without the Sprints plugged in).

The Sprints are in a powered hub (but direct to PC doesn't work either).
I've uninstalled and re-installed the Thrustmaster wheel
I've rebooted multiple times.
Disconnected and reconected both multiple times
I've even plugged the Thrustmaster pedals in (at the same time) but that didn't change anything either.
I've uninstalled and reinstalled a couple of the games. No difference.

The wheel calibrates every reboot as normal and the pedals show as responding correctly in calibration screens. This happens when they're plugged in together. It's only in-game I have the issue. Nothing will load past the loading screen.

My laptop is an Alienware M15 R3, 32GB RAM, i7 10750H, RTX 2080 Super Max Q.

I have emailed Heusinkveld support and am waiting for them to get back to me but you know how it is. New pedals, impatient, etc :)

I can't afford a new wheel until next year now so that's not an option. If anyone has a suggestion I'd love to hear it.

Thanks.
 
Messages
2
Points
1
Figured it out. For anyone else who may have a similar problem, here's what I found.

The Thrustmaster wheel and pedal set worked perfectly for ages in a (decent) powered hub.
Adding the Sprints to the powered hub made everything stop working
Leaving the wheel in the powered hub (where it has always worked) and the Sprints direct in the laptop still doesn't work.
Swearing a lot and sulking didn't seem to help.
Eventually putting the Sprints in the powered hub and the Thrustmaster wheel direct into the PC and........everything works ?!?

Happy bunny, I'm off to play.
 
Last edited:
Top