Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Rookie friendly WTCR sereis Weekly rFactor 2 events

New Build and the problems with some tracks

Messages
70
Points
61
Hi,
have you already noticed that? There are some routes that have problems with the new build. The game crashes as soon as you want to hit the track. I've had it at the following tracks so far: Blackwood, Guangdong, LochDrummond_2013_ Phakisa and Tochigi Racing Ring. Something seems to be incompatible. Does anyone know why this is ? Can users like us change something on the fly?
 
Messages
133
Points
301
Hi, you would need to check how old your versions are.

rfactor2 has gone through a lot of updates since S397 took control. Most of the tracks you listed, have been around since the old DirectX9 days. You need to check your tracks to see if or when they were last updated.
 
Messages
70
Points
61
Basically everything was set to "automatic update". But even if I knew how to find out how old the files are or even which DirectX was used, how do you get that these tracks can be used with the New Build
 
Messages
785
Points
1,142
AFAIK, if the tracks used to work, like in the months previous, then they should work now. The only one I've used is Loch Drummond, Those tracks might not have gotten the latest updates, but DX11 is several years old itself now. You would have seen ultra bright portions of the track if it was set to DX9. Automatic update only works if the author updates and uploads a new version to the workshop. On the other hand, if you are using the OLD UI, the brownish/orange one, then there will not be any updates since about Jan 2021. If any of those tracks included new features/textures etc, then the old UI may not be able to use them.
So.
Tell us what UI you are using.
Tell us what car/mod you are using.
Tell us how long ago the tracks were working(the last known good load, like a week or month or several years)
 

Durge Driven

Premium
Messages
2,866
Points
2,052
Tried 4 of 5 circuits, all worked with release candidate
You should test with a default car

btw each track in private session loaded in 10 seconds or less ....like so glacier man :rolleyes:
 

Durge Driven

Premium
Messages
2,866
Points
2,052
BLACKWWOD.jpg
GUANDONG.jpg
LOCH DRUMMOND SHORT.jpg
PHAKISA.jpg



LOCH DRUMMOND LONG LOADTIME: 11 SECONDS
 
Messages
70
Points
61
Hi ,
so I use the latest version of rFactor 2 . That is also automatically always updated .
Nevertheless, I have kept the old UI separately, which I use exactly for these tracks again. Must just rename the main folder back to rfactor 2 and of course stay offline because otherwise I would get directly again an update :( .
I also use only the original GT3 vehicles and no mod vehicles.
And of course the tracks can be loaded with the new UI , also the AI's drive well-behaved their qualifying laps. But as soon as I want to go to the next session after qualifying the simulation crashes . So a race is not possible .
 
Messages
70
Points
61
Ok, I have experimented a bit. The problem was that there are obviously some skins (from the own setting folder) that are simply not compatible with the new UI regarding the race session (and that with original S397-GT3 cars). Don't ask me why that is. After I threw these skins out of my folder everything seems to work. I had thought about this before, but who could have imagined that AI skins would be able to race in the Quali, but the game would crash when clicking on "next Session".
 

Similar threads

Replies
1
Views
530
  • Question
GTR2 LPG
Replies
0
Views
155
Replies
1
Views
377
Top