• Guest, RaceDepartment is now on Discord!  Join Here

PC Need help with MAJOR wheel issue!

Gav Elias

100RPM
Jun 12, 2011
108
22
I have a Thrustmaster T300RS wheel and a few sim games. The wheel and pedals work perfectly in iRacing, RaceRoom, F1 2015, Assetto Corsa, Grid, Grid Autosport, Shift 2 etc.

However, in Project Cars I am having a crippling issue meaning I can't play the game. The wheel seems to work fine but the pedals are all over the shop. The brake pedals doesn't get registered at all and when I depress the throttle it registers as 100% throttle and 28% brake at same time.

Clearly this means I can't play as I can brake and when I accelerate it appears to register a throttle and brake depress at same time. Obviously renders the game unplayable. It registers the same in the calibration screen and shutting game down and restarting makes no difference.

Anybody else had similar issue or know of a fix? I am using Steam version of the game and have latest updates and latest drivers and firmware for the wheel too.
 

TimeHunt

25RPM
Dec 10, 2013
40
9
Hey Gav, you need to assign your brake and accelerator pedals in the same place you assign all the buttons first.
 

Gav Elias

100RPM
Jun 12, 2011
108
22
Hey Gav, you need to assign your brake and accelerator pedals in the same place you assign all the buttons first.
Thanks! This fixed it!

I finally found these options. Stupidly i assumed choosing T300RS would have done that automatically. When i went to look, the brake and accelerator were configured to the same pedal. WTF?!?!?!?!?!?! :O_o:
 

Follow RaceDepartment