1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need F1 2011 guru to help with triggering unwanted pause in game

Discussion in 'F1 2011 - The Game' started by Sk3ptik0n, Sep 24, 2011.

  1. Sk3ptik0n


    This is an issue I had in F1 2010 as well and that bI managed to almost solve by reinstalling the game from Steam.

    When I first installed F1 2011 I played several hours without any issues, but today is happening continuosly so it looks like I have to get to the end of it.

    While driving, somehow the "pause" is triggered bringing up the menu. By observation I foundout the following things:

    It happen most often when I steer (left it seems) more than 30 degrees.

    But steering is not the only thing that brings it up. Braking sometimes does too.

    When this issue is most prevalent I will see the main screen flash black every once in a while. As if someone was trying to trigger the pause but didn't hold the key down quite long enough. This by itself is also very annoying.

    Some days are better than others (this is my experience with 2010. 2011 only started last night doing it and today suddenly became impossible to do a single lap without triggering pause at every turn.

    Now, I know that in F1 2011 (and 2010) is very easy to bring up the pause menu. ALT-TAB will do it, as well as some of the buttons on my G25 wheel that are mapped to something that should not pause the game.

    But this is pretty much all I know. Naturally, I would like to get rid of this. I may take a video of this behavior if my explanation is not enough.

    Thank you.
  2. Paul Lock

    Paul Lock

    Just some ideas / suggestions...

    Look at the game controls and make sure pause isnt mapped to the x-axis or pedal.
    Check you havent got a custom profile / macro in your Logitech profiler in wondows which is conflicting.
    Go to your controller calibration in windows and make sure none of the controls are double registering.
    Uninstall and reinstall your wheel drivers/ logitech profiler.

    Maybe the mainboard in your wheel is giving up the ghost. Could be the game, but ive not seen this problem yet. Hope you get it sorted.
  3. Hexcaliber


    Hi, this is NOT a problem with the game but a hardware problem, as suggested in the first reply check to ensure pause is not assigned to an axis on the wheel, and unplug any sticks or joy pads you may have plugged in and give it another try.

    Failing that, unplug and re insert all peripherals, keyboard, mouse, and wheel to exclude connection errors, if you can, try the wheel in a different usb port, do not use a usb port on your keyboard or monitor (often usb power supply issues can cause problems daisy chaining usb ports without additional power), plug it into a usb port in the case or a powered miniport. Also, disable any macro or device emulation software such as ppjoy, and if you are using any wireless gear, check your batteries too. If none of this resolves the problem, you have to consider that the wheel, keyboard, or possibly even your motherboard is at fault.

    If you are comfortable opening your case, try taking out all cards and memory then put them back to ensure a proper fit; over time the constant heating and cooling inside a case can cause cards and or memory modules to work lose.

    Try playing with a different controller if you have one available, joystick, joy pad, whatever (remember to unplug wheel first), if the problem continues, try assigning a different key to pause the game, something obscure like the scroll lock key on the keyboard. Also, check the list of devices in device manager and make sure nothing is amiss there.

    By this point, you should know if the wheel was at fault, by playing with a different controller; if the problem persists, you need to try to narrow down the problem, try finding a replacement keyboard from somewhere to plug in while playing. If this does not sort it, it is likely that the problem is confined to your mobo, but before looking to replace it, try re installing all device drivers, including those for the motherboard, to exclude the possibility of driver corruption.

    It is possible that something like a dry solder joint on the mobo is causing a short as the board heats up during play, but I suspect this is not something you can check for yourself given your first post.

    Essentially, whenever you press a key on your keyboard or other peripheral, a number identifying the button press is sent to the system; in your case, a device fault, device or driver conflict is causing the system to believe the control assigned to pause is being used when it is not.
  4. Sk3ptik0n


    Thanks guys, I am actually pretty familiar with hardware systems and I had already looked into some of the suggestions. For instance, I have no macros going on, I had checked the logitech software and I have remapped the pause button to an isolated key,although, in this game there are more than 1 way to activate pause, such as the Esc key, the pause key ,mapped wherever, and anytime the game loses focus. This last one is a serious contender for the issue. You may have noticed that in games like rFactor, etc. if one alt-tabs or switches focus the game keeps on playing but in the background. In f1 2010/1 the moment the main window loses focus the game pauses.

    So I'll be looking to see if by any chance there is something that is trying to bring a background program to the front.

    I also have a Momo wheel that I will use in place of my G25 to see if it happens with it. If it does, I can exclude my G25 + separate pedals.

    One problem, no matter what course of action I follow, is that this issue seems to appear in clusters.

    For instance, today I did 4 races and everything went well. No issues with unwanted pauses. I paused the game intentionally and I went to watch the recording of the Singapore GP. About an hour later I came back and I started a race in Turkey. Lap one alone I had about 6 interruptions (Until I drove off the track and hit a barrier).

    So I exited and went to do something else for 10 minutes. Came back, started a race elsewhere and it didn't happen once.

    The point is that even with a different controller I would have to use it for several days to make sure I isolated the issue.
    Anyway, you both make excellent points. One of my goals in posting here was to see if someone else was having this issue. It doesn't appear so although I am convinced it is due to the fact that F1 pauses when out of focus.

    Anyway, I will start testing the various possibilities and if I find the culprit I'll post back in case some other poor devil is having the same issue at some point.
  5. boglav


    I've had this problem too at a certain point. I almost thought the start button on my DFGT was stuck. Then my profile got corrupted and I had to delete the profile files and the issue hasn't reoccurred since. I wouldn't look too much into it, it's probably just one of those rare, weird bugs.
    You could try to backup your profile files and delete them, and reconfigure everything, maybe that would work. Anyhow, I wouldn't go the "hardware problem" way..
    Good luck.
  6. Danijel Pesa

    Danijel Pesa

    No its not hardware problem,i got same problem every 10-15 ,i just exit the game and start it again
  7. slavko.g


    Hmmm maybe keyboard problem...Usually ESC button is mapped as pause button. If not...try to uninstall completely the logitech software and drivers and then install again. Then try on default. This is so weird. I've never heard about.
  8. Ernesto De La Pena

    Ernesto De La Pena

    I have the same problem with the game, i have a g25 and clubsport pedals, i dont know whats happening
  9. jojoman


    I had the same problem as well, and guess what? It was, at least in my case, Comodo Firewall icon appearing in taskbar to remind about some updates, only to disappear after a few moments: when Comodo did so, the game paused itself on its own. I solved by disabling automatic updates of Comodo Firewall. So, look out for Comodo or something sitting in your taskbar.
  10. BugsyS


    Turn off ur web browser.Every time when browser refresh page,game will pause.I got this same problem before.Try it.
  11. Ho3n3r


    I actually once fixed a 30sec intervalled pause by figuring out that it's the Windows 7 background changing every 30 seconds. Turned it off and the pause was gone for good :)

    Maybe that helps!