Resource icon

Save Game MSC - Satsuma Just Judders and cuts out please help guys vers 2

No permission to download

Natemine

10RPM
Nov 18, 2019
24
3
24
ALWAYS BACK UP YOUR OWN SAVE

So i think i figured it out, your dash light wouldn't turn off at idle indicating something wrong with the alternator, you missed one bolt as well as your belt being too tight. you were also half empty on oil so i topped you off. the vehicle was idling at 18.0 A/F which is very lean. so i brought it closer to 14.5 for moderate power and good fuel economy. also you need to do a valve adjustment, they're not ticking, but it's definitely down on power. which can lead to the cutting out, if it that doesn't solve it, new fuel pump, as i already tuned your distributer a little bit.

Other loose bolts - Clutch cylinder (1), couple of spots for wires, gear box(2), wiring missing for rear passenger light. also a couple of bolts had not been tightened all the way on the wishbones. which probably lead to the messed up alignment causing your car to pull to the left.

YOU WERE OUT OF GAS, i also bought the extra gauge cluster as i was having a hard time with the recharging of your battery.
 

Attachments

Natemine

10RPM
Nov 18, 2019
24
3
24
Just a side note, to tune the carb you use the screw driver on the screw right in front of the intake holes for the carb.
 
Last edited:

holt97

1RPM
Dec 14, 2019
7
1
22
ALWAYS BACK UP YOUR OWN SAVE

So i think i figured it out, your dash light wouldn't turn off at idle indicating something wrong with the alternator, you missed one bolt as well as your belt being too tight. you were also half empty on oil so i topped you off. the vehicle was idling at 18.0 A/F which is very lean. so i brought it closer to 14.5 for moderate power and good fuel economy. also you need to do a valve adjustment, they're not ticking, but it's definitely down on power. which can lead to the cutting out, if it that doesn't solve it, new fuel pump, as i already tuned your distributer a little bit.

Other loose bolts - Clutch cylinder (1), couple of spots for wires, gear box(2), wiring missing for rear passenger light. also a couple of bolts had not been tightened all the way on the wishbones. which probably lead to the messed up alignment causing your car to pull to the left.

YOU WERE OUT OF GAS, i also bought the extra gauge cluster as i was having a hard time with the recharging of your battery.

Thanks very much , ooops i think i may have bodged that one together haha , thats perfect thanks again i'll take a look now :)
 
  • Like
Reactions: Natemine