RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Mods Dont Load (Both Cars and Tracks)

So i downloaded a bunch of mods but they dont seem to load. The game goes on the loading screen and then back up to the menu. This only happens with the mods (Goodwood track, and a bunch of cars) and i can't seem to find a fix for it. Any help?
 

aphidgod

Premium
Are you trying to launch a mod track in time attack mode, by chance? Most mod tracks don't support that and will crash. Try practice mode in that case.

Otherwise every mod here at RD should work out of the box. Be sure you have the folders in the right places and nested correctly. (If the content is showing up in the menus and can be selected, though, it's probably ok in that regard.)
 
Are you trying to launch a mod track in time attack mode, by chance? Most mod tracks don't support that and will crash. Try practice mode in that case.

Otherwise every mod here at RD should work out of the box. Be sure you have the folders in the right places and nested correctly. (If the content is showing up in the menus and can be selected, though, it's probably ok in that regard.)


No, i only try to load the track at the practice. They do show up in the menus. I can choose them. But when i press start it goes to the loading screen, and then back in the menus. So my guess is that it doesn't load
 

Jempy

Premium
How many mods or tracks are installed in your AC ?
If there are too many, that might be the reason of your problem .... that's what happens when you're above a certain limit.

If it is your problem, go to another launcher as CM allowing to activate and unactivate mods.
At least, JSGME does the trick, but Content Manager offers much much, more than many other options and advantages.
 
How many mods or tracks are installed in your AC ?
If there are too many, that might be the reason of your problem .... that's what happens when you're above a certain limit.

If it is your problem, go to another launcher as CM allowing to activate and unactivate mods.
At least, JSGME does the trick, but Content Manager offers much much, more than many other options and advantages.
I have about. 15 mods in total. Tracks and cars. Most of the cars are fine. The goodwood track doesn't load and the VRC Formula cars don't load either. The other mods work fine
 

Jempy

Premium
I haven't those mods installed ... but I'll give it a try tomorrow.
Except a bad install or a file missing ... I don't see why they should not load.

And if they need Shaders Light Patch to work ... this should be the reason.
And I have it of course.
 
I haven't those mods installed ... but I'll give it a try tomorrow.
Except a bad install or a file missing ... I don't see why they should not load.

And if they need Shaders Light Patch to work ... this should be the reason.
And I have it of course.
Can you link me to that patch/mod? Thanks alot :)
 

Jempy

Premium
First ... do you have Content Manager ? it's needed to use this SLP ( shortened for Shader Light Patch )

Content Manager is an alternative launcher ( and much more ) ... allowing also day-night transition, weather transition ... and surely much more to come in the future.

There's a free a bit limited version and a full version after only a small donation ( even though it deserves more than a too little small one ;) ).
 
No i don't have it, but i am more than happy to donate to get the full experience. ( Can you link me the website? Very appreciated)
 

Jempy

Premium
Not sure at all that your problem is related to that for this mod and this track .... but anyway it's a perfect tool for many other things.... and further install Shader Light Patch and more in order to have day-night transition, etc ...

You may find it here: https://**********/app/
You'll have there the lite version ... for more just follow what's explained there.
 
Top