RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Major issue with T-LCM pedals - throttle and clutch get stuck

Hi, I use T-LCM pedals connected via USB together with G29 wheel (i don't have a thrustmaster wheel).

The issue is that my pedals randomly "disconnect" from my PC when not only playing, but just testing them in the Calibration Software. The throttle pedal gets stuck at either 0 or 100% and there is nothing I can do. Same goes for the clutch pedal. The brake pedal remains working, though. They don't disconnect completely as the brake pedal remains working and they're visible in the Device Manager. The blue led light at the back is still there. Calibration Software stops detecting them and I have to plug them again. But it works only for a while.


But it happens over and over again.
What I did:
-changed USB ports (I tried all of them - no result)
-replaced the USB cable (they're recognised but no input)
-flashed my BIOS in case it's USB support problem (no result)
-tried different version of Windows 10 (no result)
-I took the whole PC apart and then rebuilt again (no result)

HOWEVER, I tested those pedals on 2 different computers and they worked perfectly fine. So I'm sure it's something related to my PC, but I have no idea.

Please help, I'll appreciate any kind of help. I'm about to freak out 'cause I have no idea what should I do and I can't race. I've literally tried everything.


PC:
AMD Ryzen 5 2600
MOBO MSI B450M mortar
RTX 2060
2x8 GB RAM DDR4
 
Made an account to reply to this, i was having different issues but they were strange enough to maybe be relevant. Go to the windows game controller section, and click on the reset to defaults area and see if it helps. I was having major issues with the throttle until i did that. Was perfect after i did that.
 
Top