Logitech H150 not working

the_sigman

7000RPM
Dec 4, 2012
7,545
2,012
22
Hello! I bought yesterday the Logitech H150 and it is not recognised by Windows. I have done some things I found in the Internet, but no result. Can anyone with similar experience help me?
 

Andrew

5000RPM
Staff member
Premium
Jun 1, 2013
5,364
3,734
@Manolis Sigoulakis
Maybe you can post, what helped you to get the wheel recognised by Windows, so that others with the same problem know what to do ?
Cheers,
Andrew Drew
- Have FUN out there. -
 

the_sigman

7000RPM
Dec 4, 2012
7,545
2,012
22
@Manolis Sigoulakis
Maybe you can post, what helped you to get the wheel recognised by Windows, so that others with the same problem know what to do ?
Cheers,
Andrew Drew
- Have FUN out there. -
It is a headset :D

Anyway, I followed the instructions I found in a thread in Logitech's forum:
  1. Make sure that the headset's microphone plug is inserted into the pink port of your sound card. Verify if it is plugged all the way in.
  2. Check if your computer has front ports for headphones and microphone. Test if the headset works with those ports.
  3. Open the Device Manager (Start > Control Panel > System and Security > System > Device Manager)
  4. Expand "Sound, Video and Game Controllers". Look for your sound card manufacturer name under the list (e.g.,SoundMax Integrated Digital Audio, Realtek High Definition Audio, etc.). Right click and choose "Update Software Drivers".
  5. Follow the instruction prompts to proceed with the update.
  6. Restart the computer if necessary.
  7. Test if the headset's microphone is now working.