Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Rookie friendly WTCR sereis Weekly rFactor 2 events

Logitech G29 suddenly gone extremely stiff

Messages
1
Points
0
Hello everyone,

this is my first time posting here, I hope I am doing it right. If not, I apologize.

I am having an issue with my wheel Logitech G29, on pc. The wheel has become very stiff, as if the force feedback was turned to the maximum potential, but the settings are still the same to the ones I've always used, both in game settings and on the logitech software. Feel has changed a lot both on ACC and F1, so I would think it's not a problem from a single game.
I tried to unplug the wheel and plug it in again (both usb and power), restart the pc, restart the games. I also deleted the saved settings and edited the original again but no results. It's a bit annoying, mostly because of the very loud noise, as the wheel seems to be operating at its maximum.
Has anyone else experienced something similar? I could not find anything specific to this on the internet, where the g29 changed behaviour completely from one day to another. Could it be hardware issue?

Thanks in advance for the replies, and once again I apologize if I posted this in the wrong place.
 
Messages
22
Points
0
This isn't from my own experience, but I recently watched a video which might give and answer to your problem:

To put it short: your issue might be about force feedback clipping, and starting the app FFBClip might correct the problem.
 
Last edited:
Messages
1
Points
1
Hello everyone,

this is my first time posting here, I hope I am doing it right. If not, I apologize.

I am having an issue with my wheel Logitech G29, on pc. The wheel has become very stiff, as if the force feedback was turned to the maximum potential, but the settings are still the same to the ones I've always used, both in game settings and on the logitech software. Feel has changed a lot both on ACC and F1, so I would think it's not a problem from a single game.
I tried to unplug the wheel and plug it in again (both usb and power), restart the pc, restart the games. I also deleted the saved settings and edited the original again but no results. It's a bit annoying, mostly because of the very loud noise, as the wheel seems to be operating at its maximum.
Has anyone else experienced something similar? I could not find anything specific to this on the internet, where the g29 changed behaviour completely from one day to another. Could it be hardware issue?

Thanks in advance for the replies, and once again I apologize if I posted this in the wrong place.
Have you fixed the issue, cause I am experiencing it now
 
Top