Keyboard keys stop working while on track (multiplayer)

Hi.

I had a fresh AC install and everything was fine. Then I installed CM+CSP+Sol. Also, RSR. No other mods. I play using a wheel.

But after I've installed these mods, sometimes while on track on a multiplayer session my keyboard keys stop working. I finish my hotlap, or spin or crash, and want to go back to the pits, but I can't, since the ESC key stopped working. I try to type something on the chat box and nothing happens. All keyboard keys stop working. Then I need to wait on track for the session to be over, so the game will teleport me to the pits, and then the keyboard restarts working normally again.

Any ideas of what might be causing this?
 

Neilski

Staff
Premium
3,755
1
1,749
UK
Not sure about the cause but have you tried Alt-Tab to get back to Windows and then the same again to get back to AC?
 
Thanks for your reply, Neilski. Yes, I've tried it and the problem persists, keyboard keys keep freezed.

I also tried the ESC key using Windows Virtual Keyboard (I open it in the background), but it doesn't work either.
 
I've experienced this. I think it's related to the new chat app in CSP.

It's like keyboard input is remaining focused on the chat window in the pre-race UI. You start the race, but your 'cursor' is still bound to a now hidden chat window where you can't do things like press esc or Ctrl+H to hide the HUD.

I fix the issue by remembering to clicking in empty space outside the chat window before clicking the wheel to get into the cockpit.

You could also try turning off the chat app in CM > Settings > Custom Shaders Patch > GUI . I'm running v0.1.62 of CSP BTW.
 
That makes a lot of sense, probably related to the new chat app - I remember now the keyboard never stops working on track when I'm practising offline.

Thanks a lot, Spondoolix. I'm going to try the empty space click. :thumbsup:
 
Top