Help! AMS Suddenly Won't Run!

newbert

500RPM
Premium
Feb 17, 2018
904
281
Earlier today, I downloaded and installed Discord as well as the SRS app (that supports their shaker kit). A few hours later I tried running AMS, but I keep getting kicked out. :( This never happened before -- AMS always ran great for me until now. All other sims (AC; ACC; rF2; R3E; PC2; K;K Kart Racing Pro, etc) all are still running fine. It looks like only AMS has a problem....

Specifically, AMS starts and I can select a car and track. But when I start the session, I'm in the cockpit in the pitstall momentarily, but then the sound cuts out and a second later I'm back at Steam's menu screen.

I'm considering uninstalling/re-installing AMS, but I can't recall whether I've installed any free or paid mods, and I wouldn't want to lose them. Should I just bite the bullet and re-install, or is there something else that I can try?

Thanks!
 

Salvatore Sirignano

100RPM
Premium
Nov 21, 2008
247
164
Earlier today, I downloaded and installed Discord as well as the SRS app (that supports their shaker kit). A few hours later I tried running AMS, but I keep getting kicked out. :( This never happened before -- AMS always ran great for me until now. All other sims (AC; ACC; rF2; R3E; PC2; K;K Kart Racing Pro, etc) all are still running fine. It looks like only AMS has a problem....

Specifically, AMS starts and I can select a car and track. But when I start the session, I'm in the cockpit in the pitstall momentarily, but then the sound cuts out and a second later I'm back at Steam's menu screen.

I'm considering uninstalling/re-installing AMS, but I can't recall whether I've installed any free or paid mods, and I wouldn't want to lose them. Should I just bite the bullet and re-install, or is there something else that I can try?

Thanks!
If you're scared about reinstalling and losing content, perhaps you could just back up your installation to an external drive or elsewhere in your hard drive?
 

newbert

500RPM
Premium
Feb 17, 2018
904
281
You could also try creating a new player profile.

Go here for additional support:
https://forum.reizastudios.com/threads/i-cant-run-automobilista-official-troubleshooting-topic.40/
Tried this as well, Thanks. Also tried some of the other suggestions in the link you provided. None of them worked.

This might be a clue though. The SRS Shake Kit that I installed this morning is essentially an External USB soundcard. It's function is to trigger the audio transducers in the shake kit and, as such, is NOT the system's default sound device. I've tried turning it off when starting AMS, but that made no difference.

Although no other sim I own has a problem with it, maybe AMS does? I bring this up because AMS crashes as soon as a sound emanates from the car in the pit stall, so perhaps there's some sound device conflict?

Just a thought, but I'd like to see your thoughts on this as well.
 

Marc Collins

1000RPM
Aug 25, 2011
1,398
551
You are likely on the right track with the sound or controller. These are what most frequently crash AMS. Since the problem started when you installed the SRS app, just get rid of it and/or the hardware as a test. Unlikely that Discord is the problem. Work backwards to reverse what you did since the time AMS worked.
 

newbert

500RPM
Premium
Feb 17, 2018
904
281
I tried unplugging the shake kit but AMS continued to crash.

So....I e-mailed SRS support (which is VERY responsive BTW) and they suggested removing SRS's dll file from AMS's "plugins" folder.

And that finally did the trick! :D So it appears that their software has a conflict with AMS, so the Shake Kit can't be used with AMS (at least on my system). But that's OK, since I have it working with my other sims.

Thanks for all the thoughts, guys!
 

Marc Collins

1000RPM
Aug 25, 2011
1,398
551
I tried unplugging the shake kit but AMS continued to crash.

So....I e-mailed SRS support (which is VERY responsive BTW) and they suggested removing SRS's dll file from AMS's "plugins" folder.

And that finally did the trick! :D So it appears that their software has a conflict with AMS, so the Shake Kit can't be used with AMS (at least on my system). But that's OK, since I have it working with my other sims.

Thanks for all the thoughts, guys!
Glad my suggestion was the right advice!

If you start a thread here asking, there may be people who have figured-out how to get the shaker kit working.
 

newbert

500RPM
Premium
Feb 17, 2018
904
281
Glad my suggestion was the right advice!

If you start a thread here asking, there may be people who have figured-out how to get the shaker kit working.
I doubt it. I started a thread asking for feedback about the Shake Kit in general and got no responses at all. Call me crazy, but I ended up ordering it anyway. I may be the only one on RD with one at this point. <shrug>