GTR2 Targa-mod crashes

stenovitz

10RPM
Aug 22, 2014
12
5
47
HI there!

Can't figure this out. :(
Running GTR2 PnG v.3.2 and Targa Florio mod-conversion by The Sky and Neel Jani from rFactor. I think the mod is back from 2011 and have been working by then.
Game now crashes at excact same spot between Cerda and Caltavuturo after some 13 minutes of driving.

Edit: The spot where the game crashes is just after a bridge between double left-hander, some 4-5 k's before Caltavuturo, I think.

I'm running the the 4GB patch.

I've tried to re-download The Sky & Neel Janis GTR2 conversion linked to here (file size is however exact to my 8 year old)

I've now tried re-install of whole game as both GTR2 standard and PnG v.3.2 on different HDD and SSD drives.

Last time I played some years ago without problems, I played Win 7 32 bit and Compatibility Mode WinXP (Service Pack 3)
Now I use Win 10 64 bit and likewise compatibility mode (triede different copability modes as well without any luck)

But result is exactly the same - game crashes at excatly same spot, just after left turn over bridge, some 4-5 k's before Caltavuturu :(

What to do? :(
 
Last edited:

GTR233

500RPM
Jun 3, 2018
639
464
I suggest to enable more cores of your CPU either with process lasso or manually after launching game with CTRL+SHIFT+ESC then click on GTR2.EXE process and enable at least 2 cores.

About Targa you can try the patch I have made :
 

Shovas

500RPM
Premium
Apr 18, 2014
980
587
Double-check 4GB (reapply it). I accidentally overwrote mine with the official patch version at one point and forgot to apply it again and was getting random crashes on big tracks until I remembered 4GB. Worth a check :)
 

stenovitz

10RPM
Aug 22, 2014
12
5
47
Double-check 4GB (reapply it). I accidentally overwrote mine with the official patch version at one point and forgot to apply it again and was getting random crashes on big tracks until I remembered 4GB. Worth a check :)
You were on the right path :)
Allowing write permission on user level for gtr2.exe did the trick.
Running the 4Gb patch afterwards did the trick :)
I.e. I think it has something to do with newer Win 10 patches and user permissions. I am quite certain I didn't had to do this playing Targa at Win 7.
 
Last edited:
  • Like
Reactions: Shovas

Durge Driven

1000RPM
Jun 17, 2017
1,779
844
62
Remember if you do a fresh OS you will lose all permissions to all GTL/GTR2/PnG folders
and any mod that has GTR2.exe in it like 10th Anniversary Patch

If you use AppCompatibilityViewer you can save them all even if you wipe sim folder it will still retain settings, extra handy if you use GME's

All you need to do is before a fresh OS export the registry from:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags


AppCompatibilityView I can't find d/l site so here is my dropbox

 
  • Like
Reactions: stenovitz

stenovitz

10RPM
Aug 22, 2014
12
5
47
Remember if you do a fresh OS you will lose all permissions to all GTL/GTR2/PnG folders
and any mod that has GTR2.exe in it like 10th Anniversary Patch

If you use AppCompatibilityViewer you can save them all even if you wipe sim folder it will still retain settings, extra handy if you use GME's

All you need to do is before a fresh OS export the registry from:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags


AppCompatibilityView I can't find d/l site so here is my dropbox

Thanks for valueable info.
I've run Win10 64 bit since the pre-release some 5 years ago and think Targa Florio have worked before without any mingling with user rights for gtr2.exe in combination with 4Gb patch, so still think this is a new thing required from a Win 10 patch update within the last couple of years.
But if I get stuck in anything, I've saved your tips. Thanks again :)