• Guest, RaceDepartment is now on Discord!  Join Here

GTL with Windows 7

Tom Wilson

250RPM
Jul 25, 2009
444
0
Damn, gives me the same error.

"The server may be running an updated or modified version of the game"

Is there any way round this or do I have to accept defeat?
 

Ben Tusting

5000RPM
Mar 5, 2008
5,764
133
Tom i was having these issues when i first went to windows 7.
Are you on v1.1?
I'm guessing your trying to join Laguna Seca? and there's a skinpack?
Did you have Laguna Seca installed and the skinpack before you applied the no cd patch?

If so remove Laguna Seca and the skinpack from GT Legends and then reinstall them. It should work now
 

Tom Wilson

250RPM
Jul 25, 2009
444
0
I've installed Laguna, the Ferrari and the Sprint Skinpack.

I'm just waiting for the Porsche to Download and i'll check it out.

Thanks guys.
 

Tom Wilson

250RPM
Jul 25, 2009
444
0
Reinstalled V1.1, this reinstalled starforce - removed starforce without applying the nocd patch and the game shortcut refuses to open either from start menu or game folder.

Same happens if i just copy the gtl.exe from the crack, what parts of the server look at for version authentication? Do you think there is a way to fool the server to get past that first check?

Getting desperate now folks, starting to think that i'm going to have to abandon the league until a solution is found for Windows 7 - which may nevetr happen!
 

Ulli Haus

250RPM
Aug 9, 2009
336
4
37
Hey Tom,

I did some googleing in 4 Languages and found a possible solution for you which requires you to make a compromise!

The september issue of a German PC Games Magazine came out with the full version of GT Legends! This version can be played without CD, which means that they have simply taken out the Starforce Copy protection which causes all the troubles!

What i can do is send you this DVD via oldschool mail, you install the Game and send it back to me!

Or, if sb has an idea how I can create an immage of the DVD and upload it somewhere, this would also be an option!

Compromise would be that you have the game in German!


Let me know!
 

Ben Tusting

5000RPM
Mar 5, 2008
5,764
133
Reinstalled V1.1, this reinstalled starforce - removed starforce without applying the nocd patch and the game shortcut refuses to open either from start menu or game folder.

Same happens if i just copy the gtl.exe from the crack, what parts of the server look at for version authentication? Do you think there is a way to fool the server to get past that first check?

Getting desperate now folks, starting to think that i'm going to have to abandon the league until a solution is found for Windows 7 - which may nevetr happen!
I didn't remove any starforce settings at all
I'l send you the link via PM, for what stuff I used Tom
 

Ulli Haus

250RPM
Aug 9, 2009
336
4
37
Well done Tom :good:

So, with the UIDATA, the game becomes english?
How big is the UIDATA folder?
 

Ulli Haus

250RPM
Aug 9, 2009
336
4
37
oh, and where did you download it from?
Cause I gave my folder to a friend in France and the game worked, but he just can't get online! I figure it might be because the game was not installed properly, so giving hhim the opportunity to download the install files could perhaps solve the problem :D
 

Tom Wilson

250RPM
Jul 25, 2009
444
0
Check the link in post #4 for the download.

The UI data contains all the data about the user interface such as menu sounds, teh menu background movies etc. I assume that it hold teh menu options in all the languages supported by the game too. But since GTL Light was inly available in Germany/Austria/Switzerland it didn't support english.

Thanks to Sam for the tip on copying that folder, It had be stumped.
 
Jun 22, 2009
300
0
Thanks Tom, I got my GTL working again.

One remark - when suffering lack of engine sound - simply execute decompress file in GTL folder. It comes with noDVD patch.
 

David Cuthill

250RPM
Jan 24, 2007
296
69
Just finished a new PC build with Windows 7 64bit so thought I share my experience so far as I just had my first club race.

On taking to the track for the first time I lost all sound on my headphones and had to re-boot. I ran the rest of the night through speakers and it was fine after that so I'm thinking that this was actually related to my sound card settings and case front-panel sockets.

On race three qualy the game crashed (but just got reloaded in time to put in a nice qualy for pole). Bit nervous about the crash as GTL has always been pretty solid for me before. Rooting around in the system logs informed me that a Data Execution Prevention error had been thrown by the game crash. So I think I'll run GTL with DEP turned off in the future.

A few ways to do this:

First method is to increase DEP system protection but exclude GTL.

1. Control Panel > System > Advanced system setting > Advanced tab.
2. Click the 'Setting' button in the Performance section at the top.
3. Choose the 'Data Execution Prevention' tab.
4. Select 'Turn on DEP for all programs and services except those I select.
5. Click the Add... button and browse to your GTL folder and select GTL.exe
6. You should now see GT Legends listed in the box with a tick.
7. Click OK in this window and after a re-boot the job is done.

If you dont want to increase DEP usage over the rest of your applications, then your other option is to turn DEP off globally. If you have a 64-bit CPU, you may have a no exectute option in BIOS.


Anybody else running with 7 had any other problems since getting it running or have any other tips e.g. Running it in Window XP compatibility mode?
 

Ryan Callan

500RPM
Sep 30, 2008
513
502
I'm on XP, but the loss of my DVD drive (long story) means I'm having to use a combination of the above solutions :/