Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

Greatly reduced framerate in VR only (Very high GPU use and frame times)

Steve D

Premium
Firstly, a bit of background. I recently moved to a Reverb G2 from a Valve Index. All was good and I was able to swap and switch between headsets without issue. (In the interests of back-to-back testing) I then lent the G2 to a colleague for a few days, got it back, plugged it in and upon launching to the grid in either AC or AMS2, (race conditions), the framerate immediately tanked to 30 / 40 FPS, GPU usage was being hammered and frame timing was anything between 50ms – 80ms. So, thinking this was a G2 specific issue, I switched back to the Index and fired up AC. Same problem! Prior to this, with the Valve HMD, I would achieve a stable 90 FPS and frame times of less than 10ms (100% SS / 150% Application) and that’s without Motion Smoothing enabled in SteamVR both globally and at the application level. FWIW CPU usage and frame times are completely unaffected. My PC spec is a mildly over-clocked 8700k/2080ti combo.

I then tested outputting to my single monitor. No problem there and I achieved a solid 150–175 FPS so this appears to be a VR specific issue.

So with the Index still in-situ, I set about trying to resolve it.

Firstly, I tried updating the Nvidia drivers to the latest version. That didn’t work and the problem remained. (Where applicable I also disabled Windows Game Mode and GPU Scheduling)

Secondly, I went down the DDU uninstaller route in Safe Mode. Upon reboot, Win 10 installed NVidia driver 432 and I left it at that to test. Success! Everything back to normal with performance as previously experienced.

However, upon updating the NV driver to the latest, (or indeed any previous version after a DDU uninstall), the framerate tanks again until I ‘rinse and repeat’ with DDU and let Windows automatically apply driver 432. I then stopped the latter happening by disconnecting from the Internet and updating directly to the latest (and also previous) drivers. Again I would enjoy temporary success and rock solid performance would return. But upon exiting and relaunching the application, or restarting the PC and relaunching, the same problem returns. Very frustrating.

Other things I’ve tried without success:
  • Uninstalled WMR Portal and Windows Mixed Reality for SteamVR
  • Fully uninstalled and reinstalled SteamVR (At the steam directory and Appdata level)
  • Varied the SS and refresh rates.
  • Enabled Motion Smoothing at 120hz (60) and 90hz (45)
  • Cleared NV_Cache
  • Used CrapCleaner and Registry Cleaner.
  • Removed HMD usb device and let SteamVR reapply it.
I’m now at a loss. I would rollback to an earlier version of Windows, (I’m on v2004), but the option isn’t available and I want to avoid a clean install if I can.

Any ideas?

Many thanks!
 
Last edited:

Andrew_WOT

Premium
Do you have G-Sync/FreeSync monitor? Try to set Monitor Technology to Fixed Refresh in NVidia. There was an issue with that in the past making HMD run at monitor refresh rate instead of 90hz.
There is an issue with current NVidia drivers, but it just causes some occasional stuttering, presume you have GeForce Experience disabled or uninstalled.
 
Last edited:

Steve D

Premium
Do you have G-Sync/FreeSync monitor? Try to set Monitor Technology to Fixed Refresh in NVidia. There was an issue with that in the past making HMD run at monitor refresh rate instead of 90hz.
There is an issue with current NVidia drivers, but it just causes some occasional stuttering, presume you have GeForce Experience disabled or uninstalled.

Hi Andrew,

Many thanks for your reply. It's not a G-Sync monitor I'm afraid so there's no Monitor Techology option showing up in NVCP. Good shout though and would make sense.

It's a strange one for sure.

After yet another DDU unistall and allowing Windows to update to driver 432, which normally fixes things, this time the GPU performance in VR issue remained. I then took incredimental steps and express installed a couple of more recent drivers, one after the other. Bingo! GPU use dropped to less than 10ms and performance returned. Had a couple of sessions with AC and AMS2 and no issues at all. Restarted the PC, jumped in to AC and the problem had returned. Same with AMS2. Have no idea what's going on.
 
Top