Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP
Gran Turismo 3 HUD

Apps Gran Turismo 3 HUD 0.3.4

Log in to download, or make sure to confirm your account via email
Amazing HUD! What exactly requires CSP in order to function? I ask because I plan to make my own original HUD :)
Thank you! CSP introduces some new python functions for on-screen rendering, which makes it possible to render the HUD properly.

im on 1.74-preview33 and the hud doesn't show up at all for some reason
Sorry about the delay, I didn't see this sooner. I don't have access to this CSP version, but if you can, it'd help me see what's wrong if you send me the python log located in Documents/Assetto Corsa/logs/py_log.txt
Usually when it doesn't appear, it means something went wrong and this file would have something useful.
 
OK DRAG FILE :) not "install from file"
amazing!!!!
ok.png
 
Last edited:
I'm using CSP 0.1.73 but it doesn't work at all... :s
I suspected that it was due to the window mode(1366x768)
and tried full screen(1600x900), but it didn't change.

p.s. I tried it on a vanilla car(Mazda MX-5 Cup), but it didn't work due to the same error.
 

Attachments

  • py_log.txt
    19.5 KB · Views: 9
Last edited:
I'm using CSP 0.1.73 but it doesn't work at all... :s
I suspected that it was due to the window mode(1366x768)
and tried full screen(1600x900), but it didn't change.

p.s. I tried it on a vanilla car(Mazda MX-5 Cup), but it didn't work due to the same error.
i've resolved dragging file in content manager, not install from file
 
Hey there!
Any chance there would be a way to lock this to the centre screen? Using this with a triple screen set-up and it puts the in car HUD on the far right.. :(
 
im having a problem with the hud after switching my setup from my 21:9 monitor back to a 16:9 one. the 21:9 one is still plugged in and im guessing this causes it to auto detect that monitor as it placed off centre. any thing i could do to resolve this? cheers in advance!
 
I have all up to date (Sol, CSP (Patreon ver) etc) but the HUD doesn't come up even when checked and enabled in Content Manager and in game. Any ideas?
 
I'm using CSP 0.1.73 but it doesn't work at all... :s
I suspected that it was due to the window mode(1366x768)
and tried full screen(1600x900), but it didn't change.

p.s. I tried it on a vanilla car(Mazda MX-5 Cup), but it didn't work due to the same error.

Looking at the log, it seems to be correctly detecting 1600x900 but I see something happens with another app and then it stops working. Can you try perhaps disabling all other apps and run it alone to see if this persists?

If that works, do let me know what other apps you were using that it didn't get along with the HUD.

Hey there!
Any chance there would be a way to lock this to the centre screen? Using this with a triple screen set-up and it puts the in car HUD on the far right.. :(

im having a problem with the hud after switching my setup from my 21:9 monitor back to a 16:9 one. the 21:9 one is still plugged in and im guessing this causes it to auto detect that monitor as it placed off centre. any thing i could do to resolve this? cheers in advance!

I haven't tried anything using a multi-monitor setup. But I do plan on including a manual resolution override that could solve this and the windowed mode problem. I'll try to give a triple monitor setup a go to work out issues with it.

The app attempts to auto detect the resolution of the main monitor the game is running and uses it to display the assets, currently. And that only happens to work with single-screen, full-screen mode.

I have all up to date (Sol, CSP (Patreon ver) etc) but the HUD doesn't come up even when checked and enabled in Content Manager and in game. Any ideas?

If it's enabled in-game and it doesn't show up and you're running in windowed mode, the HUD is happening to be off screen.

If not, then I'd need to look at the py_log to see what errors are happening. You can find it on Documents\Assetto Corsa\logs\py_log.txt, the log entries regarding the app will be preceded by [GT3 HUD].

Great Work but the lap times is incorrect in multiplayer.

Thanks for letting me know, I haven't had a chance to try this in multiplayer. I'll keep a note of it and try to find out what's happening. If there are any other details you'd like to share, I'll appreciate it.
 
Looking at the log, it seems to be correctly detecting 1600x900 but I see something happens with another app and then it stops working. Can you try perhaps disabling all other apps and run it alone to see if this persists?

If that works, do let me know what other apps you were using that it didn't get along with the HUD.





I haven't tried anything using a multi-monitor setup. But I do plan on including a manual resolution override that could solve this and the windowed mode problem. I'll try to give a triple monitor setup a go to work out issues with it.

The app attempts to auto detect the resolution of the main monitor the game is running and uses it to display the assets, currently. And that only happens to work with single-screen, full-screen mode.



If it's enabled in-game and it doesn't show up and you're running in windowed mode, the HUD is happening to be off screen.

If not, then I'd need to look at the py_log to see what errors are happening. You can find it on Documents\Assetto Corsa\logs\py_log.txt, the log entries regarding the app will be preceded by [GT3 HUD].



Thanks for letting me know, I haven't had a chance to try this in multiplayer. I'll keep a note of it and try to find out what's happening. If there are any other details you'd like to share, I'll appreciate it.
This is what it says in regards to the GT3 App:


Setting up the main window
[GT3 HUD]: 'Attempting to fetch odometer reading for wm_nissan_r33_flat'
[GT3 HUD]: 'Fetching odometer reading for wm_nissan_r33_flat from Stereo'
[GT3 HUD]: "Stereo's odometers.txt not found"
[GT3 HUD]: 'No readings found from Stereo. Attempting Sidekick.'
[GT3 HUD]: 'Fetching odometer reading for wm_nissan_r33_flat from Sidekick'
[GT3 HUD]: 'Found odometer from Sidekick: 63354.76705346349'
[GT3 HUD]: 'Opening best lap for: WM_NISSAN_R33_FLAT@DEEPFOREST_RACEWAY-NORMAL.'
[GT3 HUD]: 'No personal best found.'
[GT3 HUD]: 'Initializing. CSP version: 0.1.76-preview1 (1617)'
[GT3 HUD]: 'Settings loaded.'
[GT3 HUD]: 'Detected screen dimensions: 1920x1080'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'


[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT HUD: error] Traceback (most recent call last):
File "apps/python/GT HUD\GT HUD.py", line 1573, in acUpdate
tyre_temperatureI = info.physics.tyreTempI
AttributeError: 'SPageFilePhysics' object has no attribute 'tyreTempI'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'

[GT3 HUD: error] Traceback (most recent call last):
File "apps/python/GT3 HUD\GT3 HUD.py", line 86, in acUpdate
hud_info.update_info(player_car, deltaT)
File "apps/python/GT3 HUD\common\HudInfo.py", line 88, in update_info
self.__update_static_info()
File "apps/python/GT3 HUD\common\HudInfo.py", line 140, in __update_static_info
self.is_turbo = bool(sim_info.static.maxTurboBoost)
AttributeError: 'SPageFileStatic' object has no attribute 'maxTurboBoost'
 
BlowOff Valve
I turned off this app and it showed up, but there was another problem...
HUD position is messed up when in windowed mode :/

The HUD has no support for windowed mode yet, it will only work properly on full screen, single screen setup.

Windowed mode and multi-monitor setups are still a WIP.

Btw, I will try to investigate what may be causing the HUD to be misbehaving with the app you showed. Thank you for the insight.

This is what it says in regards to the GT3 App:

...

You seem to be having the same problem as -Ike|XIV- had, can you try turning all apps off and run the HUD alone to see if the problem persists? Or, in his case, since it seemed to work when he turned off BlowOff Valve, if that works for you too?

Because both of your logs had problems with the turbo boost information.
 
The HUD has no support for windowed mode yet, it will only work properly on full screen, single screen setup.

Windowed mode and multi-monitor setups are still a WIP.

Btw, I will try to investigate what may be causing the HUD to be misbehaving with the app you showed. Thank you for the insight.



You seem to be having the same problem as -Ike|XIV- had, can you try turning all apps off and run the HUD alone to see if the problem persists? Or, in his case, since it seemed to work when he turned off BlowOff Valve, if that works for you too?

Because both of your logs had problems with the turbo boost information.
Afirm. I disabled all apps, reinstalled your one and now it's working. Thank you.
 
Top