g29 appears ok in Options menu, but car doesn't move

Hi. Trying to use my Logitech G29 wheel in SCE. There is no profile for g29, but g27 or a fresh profile both seemed to work in the options menu. The test charts for steering, brake and accelerator all work fine in the options menu

In game, the steering and accelerator also seem to work, but the car will not move. It feels like there is a very strong handbrake on! I can produce revs and select first gear, but car doesn't budge. Any ideas?
P.S. Auto-clutch is on. I've also assigned a button for handbrake and toggled it. Nothing works

So I guess I haven't set up the wheel properly, but can't see how to

I've searched in this forum and on google to no avail

The wheel works fine with other games like AC and PCars.

Any pointers?


What track are you using?

Even if you see your controllers working in the status display... go ahead and remap your controls to make sure the correct axis are setup for throttle, brake, and clutch if you have it.
Maybe press "A" (or the mapped button) so the AI take the car out of the pitlane, then press it again and try to understand what happens when you regain control of the vehicle. It should give some other clues.

Right now I don't have any idea of what is causing it.
Sorry about the delay answering, I had problems with my account but all good now

Thank you very much for the suggestions. I have re-mapped the steering, accelerator and brake (in Controls/ Primary Controls by pressing the relevant pedal/ turning the wheel, and re-saving under different profile name). This didn't seem to change anything

The track is Interlagos 1.

But i think we might be getting somewhere with the suggestion to use AI to get out of the pit. This worked well, and once on the track and turning off AI, I found that I could steer the car with the wheel, but the pedals still not working.

Does anyone have any ideas about what to do if the wheel is working OK but the pedals are not working? (I checked the pedals on other games and they work fine)

Any thoughts appreciated. I can't wait to get started with this game!
That's even more strange.

The pedals are not working, but before you said you could produce revs... Did the car stall after leaving the pit? And did you see the color bars raising while you were remapping the pedals (including clutch)? It doesn't make much sense that they are recognized in game, but not on track. Maybe @Renato Simioni knows something about it.

I would turn all assists off and try to use the clutch to start moving.
Yes it is strange. When I use the pedals in the Options section the red bars move OK.

In game, when I accelerate the revs go up, all the way in neutral. When I select first gear, the revs still go to about 4000, and when I select 2nd gear the revs go to about 2000. But the car does not move!

I do not have a clutch pedal, since I moved the brake over to the left position for easy 2 footed acceleration and braking. But I will try and map a button for clutch operation.

P.S. after the AI got me moving, and then i turned it off, the brake pedal did not stop me either. It too works with red bars!
Oh, you physically removed the pedal?

Well, the revs going to 4000 and 2000 is due to the speed limiter. I think L or space (or whatever button you assigned) turns it off.

But the brakes not working makes no sense... If they show on the red bar, they should work. Are you selecting the G27 preset on the menu? It shouldn't matter anyway, as you are reassigning the controls...
Bingo !

I had most assists off, but turning every single assist off OR re-mapping the clutch has done the trick :)

So I have 2 theories about what caused the problems
(i) an assist e.g. brake help or something (I will now gradually add them back in)
(ii) the clutch was inverted, so always depressed

Anyway, I am off and running

Thank you very much Heitor !
Just to confirm - the problem was the clutch.

I was mistaken about the brakes. The problem was that the clutch was fully deployed. No signal was coming from the pedal, but it must have been inverted so it thought no signal meant fully depressed. Assigning a button to clutch operation solved it.

And yes, I physically swapped the brake and clutch to allow easy left-foot braking, as I always drive auto or semi-auto using paddles on the wheel to change gear. The clutch is now in the middle and not connected as the cable was too short.

Thanks again for the help


I also had this problem with Logitech G920. Reading this thread solved my problem.
The problem WAS the clutch..(thanks for the pointer),all i did to fix was select "inverted" for the clutch assignment,that sorted it. Many thanks :)
Top Bottom