G27 profiler not launching

Discussion in 'Sim Racing Hardware' started by Crashhard Banger, Jun 7, 2018.

  1. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    I was playing rFactor2 - no problems. I quit to desktop and installed a new GeForce Experience driver update. Now my Logitech wheel profiler won't launch. I've re-installed the software and the wheel is detected. All the buttons are still mapped etc.. but the FFB is way too heavy and the rotation feels like it's gone from 900 degrees to 450. It's undriveable and I have no profiler to reset it.

    Any ideas, anyone?
    Cheers
     
  2. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    Update: I booted up this morning and profiler still not launching. I went into Devices and selected the wheel which allowed me to manually configure it. For some reason it was locked at 180 degrees last nite - but now back to 900 again.
     
  3. Jeron Bleeco

    Jeron Bleeco

    Messages:
    57
    Ratings:
    +20
    Profiler still won't launch ? backup or delete the logitech folder in Documents folder. One of the profiles unfortunately gets corrupt i guess....anyways this will launch a new one. Also I recommend once u get your settings right on new profile, save a backup of the new Logitech folder in Documents folder. Hope this helps !
     
    • Beer Beer x 1
  4. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    Thank you. Unfortunately there's deeper lying problem. I uninstalled the old software and reinstalled - but when I click the icon in start-up menu nothing happens. I open the file location of the icon shortcut in the start menu and check properties. It should show the path to the software app and allow you to open file location. In this case the target is greyed out - and there is no file location!! I opened the Logitech/Gaming Software folder and the app is missing - although everything else seems to be installed.

    Also the ProgramData folder in my C drive was hidden for some reason. I clicked show hidden files and it was there but greyed out. I made it unhidden - but got a message saying some files could not be shown. Also, one of my video editing apps won't launch either. Dunno, I have gremlins and think a full re-install is required. Not looking forward as last time it took a whole weekend :(.
     
  5. RasmusP

    RasmusP
    AC Stuff and G27 help Staff

    Messages:
    3,825
    Ratings:
    +1,335
    The "ProgramData" folder is always hidden and protected. Totally normal! This is how it looks for me (German Windows):
    upload_2018-6-21_11-25-36.png

    To the Logitech problem: I sadly have no clue about that. I never had to change anything there though since most games have a direct rotation setting or like Wreckfest and Dirt Rally: "Saturation".
    Spring, Damper, overall strength shouldn't be needed to be modified too from my experience so in theory as long as you can set it to 900° everything should be fine.
    Btw, holding down the two red buttons in the middle of the shifter + pressing one of the round black ones will switch the rotation to:

    Top: 240 degrees

    Right: 670 degrees

    Left: 450 degrees

    Bottom: 900 Default

    In general it seems that the nvidia drivers like to screw up lately.. Had it some months ago that every time I uninstalled and reinstalled the driver some other part was uninstalled. Physx, no sound, no geforce experience.. It was a pain and windows aero got disabled too about that.

    Now I'm doing two things: every 2 weeks I run Paragon 2016 (it was free for some time, watch out for something similar!) and backup my whole system. Takes about 15 minutes and with a 250GB SSD only 65GB on a standard HDD. Never be bothered again if something goes nuts with Windows!

    Then in general my stand is that you don't need to update the geforce drivers every time it comes out. I just disabled the message about updates and be happy. When you look in the changelogs it's mostly only about the new games and I personally barely play new games. And even if I do it never caused problem. Maybe 2-5 fps lower performance.
    For older games nothing changes. If your graphics card isn't just released (in my case almost 2 years old now, GTX 1070), there aren't any real changes so I don't bother with updates anymore.
    Every few months I make a backup and install the newest driver. No need to screw my system!
    No idea what Win 10 and Nvidia are doing lately but all I see are broken systems, lol :cautious:
     
    • Beer Beer x 1
  6. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    Damn! I didn't realise the ProgrammeData folder is supposed to be hidden! I've probably screwed something else up now. I'm a lifelong Mac user, only built my PC a few years ago to play games after my PS3 died.

    My wheel works without the profiler - but every time I boot up it defaults to 180 degrees. I have to go to devices, select G27 Racing Wheel / Game Controller Setting / Settings and untick and re-tick Game Settings - Allow Game to Adjust Settings. Then the wheel is back to default 900 degrees. I have Spring / Damper Effect Strength at 0% and Centering Spring off like you said. It's just a pain because I don't always remember to do this and have to quit the game. At least with the profiler, it runs in the background and has the correct setting for each game so i don't have to manually do this every boot up.

    I think you're right about GeForce drivers not being needed to be updated every time. I'm not a big gamer, only play racing sims, that's it. I'm going to have to do a full re-install at some point anyway, because I need that video software working to finish some projects. I'll look into Paragon or some other back-up software. Thanks for all your advices. Much appreciated :thumbsup:.
     
    • Like Like x 1
  7. RasmusP

    RasmusP
    AC Stuff and G27 help Staff

    Messages:
    3,825
    Ratings:
    +1,335
    Spring and damper can stay at 100%. Most Sims don't use them anyway and the Sims that do (dirt Rally is the only one I know of), rely on it as part of the ffb!
    AC only uses the damper slider when going below 3 kp/h to simulate the wheel scrubbing at low speeds.

    Just let it on default and use the hotkey to switch to 900° :)

    To reinstall: try ddu to get rid of it completely and then install the latest driver with default settings. Every time I try to adjust the install settings in the geforce setup it screws up something...
     
    • Like Like x 1
  8. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    Just looked up DDU. I'll give it a try tonite and see if it cures the problem. Might save me a full re-install. I'll let you know how I get on. Cheers!
     
    • Like Like x 1
  9. Crashhard Banger

    Crashhard Banger
    Premium

    Messages:
    199
    Ratings:
    +143
    Update - I wanted to join an R3E race but it wouldn't launch. Apparently it requires the profiler to launch?!?! :O_o: Doesn't make sense to me. Anyway did a full re-install - bit of a pain to re-install my STEAM library and software - but is profiler working again as is everything else :). All is well - until the next time something goes wrong!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.