G27 Pedal Bug? Brakes/Throttle are constantly being applied.

Travis Austin

1000RPM
Oct 15, 2011
1,211
272
22
everytime i go into a session, whether its time trial or quick race, the 5 lights go out to start my flying lap, and my car just stops. and it sounds like the throttle and brake are being applied at the same time. ive tried moving the brake pedal to a button but then the throttle is being applied automatically. and vice versa. but when the brake is moved to a button, the throttle works, but it acts as if the brakes are being half applied. the car accelerates very slowly and will only go up to 82mph in 2nd gear. anyone else having this problem? if so, have you found a way to fix it? this is making me so frustrated!
 
  • Like
Reactions: Freyk

Dick Hobbs

100RPM
Jan 26, 2014
151
13
do a custom profile and everything will be fine
In other words, In game go to My F1 / Settings / Custom Controls / Driving Controls and set up your Wheel button assignments, when you're done, make sure Input Device = CUSTOM and Control Presets = CUSTOM (greyed out).

I have a G27 and spent the first 2 hours on release day, trying to get out of the pit lane.
 

Travis Austin

1000RPM
Oct 15, 2011
1,211
272
22
In other words, In game go to My F1 / Settings / Custom Controls / Driving Controls and set up your Wheel button assignments, when you're done, make sure Input Device = CUSTOM and Control Presets = CUSTOM (greyed out).

I have a G27 and spent the first 2 hours on release day, trying to get out of the pit lane.
i've been using custom controls. but when the bug is doing it's stupid job, i try to reset the brakes and throttle controls and it thinks that the throttle and brakes are "slider 1"
 
Oct 25, 2010
307
37
I have the same issue - the custom settings do not work either.

I use the clutch as a brake for F1 201X (always have) and in this version, it thinks that its always depressed. This results in having to push both pedals in to get the car to move, but as soon as you let go of the clutch, the car spins to a stop.



as a result, I am forced to use what CM has defaulted for the axis.

I have noticed that while driving, the FFB kicks out (with and without vsync) on my wheel, but will randomly be applied to my flight stick.



Seems as if this time around they really messed up the control imputs :(
 

Tronneh

10RPM
Jul 14, 2015
14
18
I fell for this too as i use the clutch as the brake.
The fix is quite simple, all you need to do is invert the input.
Create the custom profile, goto Brake/Reverse and press F2 and you should see "Action Inverted" next to the axis on the right.
 

Travis Austin

1000RPM
Oct 15, 2011
1,211
272
22
figured out how to fix it. open up the Logitech profiler and let it load up before opening f1 2015.shouldn't have any problems after that.
 

Monty987

1RPM
Aug 4, 2014
5
0
33
if you set it up as a custom controller then the pedals seem to have a massive deadzone (for me at least)

any suggestions?
 

Travis Austin

1000RPM
Oct 15, 2011
1,211
272
22
if you set it up as a custom controller then the pedals seem to have a massive deadzone (for me at least)

any suggestions?
a lot of people are complaining about a massive deadzone with the pedals. i dont think there is any way to fix it:(