Freezing on start up after deleting track/car

I have searched long and hard but cannot find a solution to this weird problem. I recently purchased a new computer which has Win 8.1. I saved all my old mod folders for GSCE from my old PC (Win7). I installed GSCE on the new computer (non-steam), as well as Beta (steam) and both work no problem.

The issue I had was with my modded folders for non-steam install. On my old PC I had GSCE main (untouched) plus separate installs for my mods with only have the relevant tracks/folder in them (for example a Champcar and separate V8 Supercar install). I had no original tracks or cars in each of these installs (they remain in the main). I previously had no problem with this.

On my new computer, I simply copied and pasted my new original install (x2) and transferred over all my mod cars/tracks into each folder. Loaded up and everything worked great (mods/tracks). But when I go back and try delete the original cars/tracks the game no longer loads and I get a dmp. If I restore the track/s I deleted it works again. To test I tried the same on the original install (i.e. no modifications) and if I delete a single original track/car the game wont load. I tried everything to work out a solution, gave admin rights, deleted player, GSC Sync etc, checked around the web but can find no solution. Even tried a Lite install but no luck. All installs are up to date.

Does anyone have an idea what may be causing this? I have a fair amount of experience on modifying rfactor/gsce but for the life of me cannot work out what is causing this so decided it was time to post here for possible assistance. Thanks in advance
It may be something to do with registry entries. It would be better to install it properly on the new pc, rather than copying it across. And then copy any extra installs across from that one. Then copy you gamedata and other stuff across form the old pc. I don't know the answer, but that's the only thing I can think of trying.
Thanks Keith. I actually did install GSCE on the new PC (no copying of anything, fresh install). Then copy and paste the new fresh install and added my gamedata (the tracks/vehicles/sounds/talents I wanted only) to the new ones. It works fine, until I then begin to delete the original tracks/vehicles. It is weird, the failure to launch even happened after I deleted a single track from the standard new install. Not sure if it is a Windows 8.1 issue. When I deleted my player (copied over from the new original install to save time) the game would start, but when I entered a new player name it froze at that point. Anyway thanks for the response, I can still play my mods on the 2 copied separate installs, I just have to have all original tracks and vehicles sitting along side my mods. That will have to do until I work out a solution.
Top Bottom