Formula Trainer skinning issue.....

MadBronco

10RPM
Original poster
Feb 2, 2013
12
40
49
Hi Guys,

You may have seen i am painting a skin pack for the Formula Trainer, i posted some wip screenshots recently. It is coming along nicely and nearly finished, taking longer than i would like but what mod doesn't? Anyway i thought i would put a couple in game to see how they looked and turn a few laps as i have been using the viewer to paint. And that is where i came across the issue of what showed with the viewer didn't show in game.

In the template there is a layer called 'black parts' which concerns the cockpit screen, sides, headrest and rollover hoop, this layer is not locked or anything and can be painted on as can be seen in the first screenshot where i have painted the orange stripe and placed the drivers name to match the car the skin is based on.

Untitled1.png


Untitled.png


But as you can see from the second screenshot the orange stripe and name do not show in game and i can't work out why this is. I have played around with different layers before exporting the .dds, that didn't work and i have even had a look at the model, which did reveal the body has 2 materials. One for the main part of the body and one for the screen, sides etc, basically the parts using the 'black parts' layer, but apart from a couple of effects layers the main texture is the body texture for both so in theory the stripe and name should show. I can only guess these parts will always be black no matter what you paint on the template because of some code or something, i may be wrong and just missing something.

So the point of this post was to ask if anybody had come across the same of things not showing in game and more importantly if there is any solution or workaround. I would like to fix this but it is not a deal breaker if i can't and i will just have to go without the stripe and move the name down under the roll hoop on the body.

Thanks,