Fix my Satsuma please

Save Game Fix my Satsuma please 2019-11-28

No permission to download
Apr 28, 2019
4
3
18
Hai EduardPWN,

I haven't done this in a while so it took be a bit longer than usual but I have looked into your car and found a couple of things:
Appropriately fixed the gear stick (there were 2 gear sticks in 1, never seen this before)
I have changed the batteries
I have fixed the tightness of the alternator belt
I noticed there was/is no water pressure.
And the racing radiator is/was not starting. I have tried my best to find out what was causing this, I still am unsure as I haven't done this in a while so I have forgotten what could cause this and/or if this is normal. I did refuel the coolant of the radiator and this did magical wonders.
I have also ' tuned' your carborators so the engine won't stall.
I have also fixed your starter motor as the condition of it was very bad.
I have noticed that your back tires are not in very good condition but I have kept it like it was.
I made sure every bolt that should have been bolted was bolted.
I have also changed the RMP gauges to 7000RMP to light up.

I have also test driven your car and in my opinion it works fine.
Don't hesitate to ask for help again, I do love me a challenge like this one ;)

Kind regards,
Schak Bruijn
 

Attachments

  • Love
Reactions: EduardPWN

EduardPWN

1RPM
Nov 28, 2019
3
1
18
I appreciate your work and i see the problems with my car :)) I know it took a while and i wanna say thank you :*! But now, it s probably from my pc, i can't shift up or down the gear..
 

EduardPWN

1RPM
Nov 28, 2019
3
1
18
And also, the smoke coming from muffler it s sometimes white and sometimes black without my intervention, idk if this is normal, i m a noob
 
Apr 28, 2019
4
3
18
Hai,

Hah I have also changed some settings as I have to be able to drive the car. I have enabled the 'H-shifter' function in the game. This should be disabled if you're going to use keyboard and mouse ;)
I also noticed the high amount of smoke coming from your exhaust, which I have also mounted back onto your car. I can't find a proper reason why it is producing so much smoke. As I said I haven't done this in a while and for now the car, in my opinion, seems to be working fine. Even at high speeds the car works fine.
I hope you will be able to use the car properly again ;)

Greetings,
Schak Bruijn
 
  • Like
Reactions: EduardPWN