Fanatec CSR PS3 Mode

Discussion in 'Sim Racing Hardware' started by Charlie Gould, Jan 21, 2013.

  1. Charlie Gould

    Charlie Gould

    Hi everyone

    I got a Fanatec CSR Wheel, CSR Pedals, and CSR Shifter Set for christmas. I love it, I enjoy rfactor, race 07 etc so much much more than with a pad, and have also joined iRacing. My Xbox games are better aswell, but I had an msoft wheel so it was just a hardware change on that front.

    Anyway, I recently bought WRC 3 for PC,and was shocked to find, that the CSR is not supported, I can map the controls like a pad but that just gives a horrible experience. I then downloaded the EC Sim Hardware v1.1 plugin, and the wheel actually works now, however, there is still no force feedback.

    After some research, on various sites including, people seem to be saying ut the wheel in PS3 mode to make your PC think its a Logitech G25. I tried following the Fanatec quick guide and the downloadable manual, but the wheel just goes into PC mode and stays there.

    Im on Firmware 706 with driver 115, there is an issue with the update on my PC, as I just get ERROR 2 when i get to the flashing stage, sometimes i get to the second Flash phase, but i get ERROR 2 there as well. But thats for another thread

    Help with either issue would be very much appreciated. Thanks!
  2. Kjell Eilertsen

    Kjell Eilertsen

    I haven't tried this myself but in another thread here at RD it was mentioned that you need to uninstall the Fanatec drivers entirely to get the wheel into PS3 mode.

    As for the update problem, make sure you follow the guide to the point, particularly disabling antivirus, fanaleds and any other unnecessary software while updating.