Fanatec Beta 352

niko911

25RPM
Mar 13, 2019
39
4
49
Hi,
Going crazy after several hours trying updating to the new Fanatec 352 beta driver.
Tried to register on the Fanatec forum, but "Page mot found"...so I cant get any help there.
The problem is that everything screws up. Flashing the Podium with the new driver, turns the Podium 2 to a XBOX periphial!!!
(Does not show up as a gamecontroler on my PC - the Podium internal fan goes high speed and nothing works...)
Downgraded the drivers to the old ones, the Podium works now, but the Fanalab does not..
Anybody have simular issues? (getting a support ticket will take several days)
Best regards //Niko
 

psynusoid

100RPM
Premium
Jan 10, 2016
182
120
44
All I can suggest is that you go through the upgrade procedure again but this time slowly and carefully. Its not exactly obvious.
Update the driver to 352, Update the wheel firmware, Update the motor firmware, Calibrate the wheel (can be done from the driver properties page - read the instructions in the popup)
The old fanalabs software doesnt work so uninstall it and there is a new version this was very clearly mentioned on the beta driver release page.
To switch between modes PC/COMP/XBOX use the 2 squares button and Y (with the universal hub)
 

Chrhun

100RPM
Premium
Feb 25, 2019
120
48
42
I tried the beta drivers yesterday and nearly bricked my new DD2. It went into XBOX-mode, fan full blast and would not accept the mode change. The base was not recognized by Fanalab or by Windows game controller settings. I had to put the wheelbase into the bootloader mode and flash it back with the older drivers, and I think I got it back to normal.

I think I will try it again today.
 
Last edited:

Aarup

Aarup
Premium
Sep 25, 2012
76
40
37
I tried the beta drivers yesterday and nearly bricked my new DD2. It went into XBOX-mode, fan full blast and would not accept the mode change. The base was not recognized by Fanalab or by Windows game controller settings. I had to put the wheelbase into the bootloader mode and flash it back with the older drivers, and I think I got it back to normal.

I think I will try it again today.
Did you update motor firmware after updating the wheel firmware?

It's normal for the base to go full fan after upgrading the firmware until you also upgrade the motor firmware.
 

Chrhun

100RPM
Premium
Feb 25, 2019
120
48
42
Thanks! The issue was that I could not upgrade the motor firmware as the base was not recognized by my computer. That was probably due to the XBOX-mode, but I was not able to change that.
 

Aarup

Aarup
Premium
Sep 25, 2012
76
40
37
Thanks! The issue was that I could not upgrade the motor firmware as the base was not recognized by my computer. That was probably due to the XBOX-mode, but I was not able to change that.
Ahh, sorry didn't catch that. Yeah then it looks some sort of error. On my DD1 it just said that I had to upgrade the motor firmware when I opened the Wheel Properties after the first firmware update and the fan went back to normal speed.
 

Chrhun

100RPM
Premium
Feb 25, 2019
120
48
42
I did the installation again, taking great care to go step-by-step. This time I managed to get the mode changed to PC after the wheelbase firmware installation, and then proceeded with the motor FW installation. Then I calibrated the motor and wheel center and everything seems to be working now as it should. Now some testing with the new settings!
 

psynusoid

100RPM
Premium
Jan 10, 2016
182
120
44
I've had the wheel lockup - no response from buttons anywhere including the power after going into the setup menu a couple of times with this firmware. Shutdown and power-off of machine and wheel and then its all worked again.
I think its when you do a motor re-calibration. Hasn't happened since....
 

Chrhun

100RPM
Premium
Feb 25, 2019
120
48
42
I drove a bit yesterday, but can't say anything conclusive as the level of FF was different with the same settings and the new drivers/FW. Less strength in wheel, so I guess I felt FFB a bit clearer, but I need to tweak the settings to get a bit of intertia (like the drift mode -2 in the past) back.