• 23000+ Members! Dear Guest, join the community on the official RD Discord server today.   learn more

Fanatec 2.5v and Protosimtech PT1 pedal combo?

Roscoe__

1RPM
Apr 26, 2019
2
0
36
Hi
Im having problems with my Protosimtech pedals, every time i use the clutch the pedals disconnect from the PC but if i only use the brake and accelerator the pedals work fine. I have replaced the potentiometer on the clutch also replaced the Leo Bodnar Board but still does it. I think its conflicting with the fanatec 2.5v because i had no problems with the pedals on version 2. i was just curious if anyone else has the same setup and hasn't come across anything similar.

Thanks
 
Sep 7, 2018
2
0
53
Hey Roscoe. Find a fix? I have a Simucube(grounded), PT1 pedals and have the same issue. It happens only when using a clutch. I have also replaced the pot and board and i still have the issues. I get usb disconnects every couple laps when using the clutch. I had the pedals connected via a hub so i tried direct connection to the Mobo and that didn't work so i tried to a powered internal card and that also didn't work. I tried usb suspend settings for all peripherals as well. Still happens.