F1 2015 video setting can't be changed - plz help

Discussion in 'F1 2015 - The Game' started by Saturn, Jul 17, 2016.

  1. Yes both graphic & Audio doens't work as intented even after restarts

  2. No the game's graphic and audio do what I tell it to do

  3. I have only had problems with the graphic as stated in the question

    0 vote(s)
  4. I have only had problems with the audio as stated in the question

    0 vote(s)
  1. Saturn


    When I start F1 2015 (the 2014 season,) it worked fine for quite a while, but since a few days ago something has happened that seems like a bug. When I venture into the options menu selecting graphics & then later, the audio tab, I see constantly that the game has chosen to use "custom"- graphics, instead of high or ultra high which I normally use. It doesn't matter if I choose medium or lower settings, it still remain on custom when I restart.
    Most of the settings are on ultra besides those who can't go higher than "high". The settings that are on low are the ones at the bottom for some reason. If I remember correctly it is three settings that's always on "low", and two settings which always are switched off (it says "intel" besides the option, I have an intel processor but it doesn't seem to work anyway, why can't I activate them as I have an intel processor?). I try to change the three settings which are on "low" to a higher setting, medium, high or ultra but to no avail. It seem to work as it ask me if I want to keep the new higher setting and when I accept it tells me to restart. When I restart, the settings revert back to "low". I also try to change the custom setting at the top to change every setting at the same time but that doesn't work either.

    One last thing, when I go into the audio settings you can choose audio quality. Mine is set to normal, but this wasn't always the case, so I try to change it back to high as I always was able to do this earlier, perhaps a new patch has frackt it up? The game then again states that a restart is needed but this doesn't help. I could always use the highest audio quality but now I can only use "normal" quality.
    Please can someone enlighten me on what I can do to make this work as it did before?

    PS: I have checked the file integrity yesterday (July 16) on Steam and repaired one file that was corrupted

    Sincerely Yours


    I have Windows 10 64bit, legally. (But I can't for some reason update the latest patch)
    My hardware consists of:

    Processor: i5 quadro 4th gen; 3,40GHz (4670K),
    Video Card: Nvidia GTX 960 2GB,
    Memory: RAM 8GB 1600MHZ,
    HDD's: SSD disk which I use for windows and games that need much capacity, + 2 standard HDDs for saving larger files and such,
    Power: Net-aggregate at 800-WATT,
    And lastly: A motherboard that will be able to last a few year more (I always buy a really good motherboard so I don't regret it later) buy sadly I can't remember the name on the top of my head right now.
    (Not that I think it matters but I have a 4K 50' TV)

    And for car games and simulators I have a G27 with a broken clutch. If someone have any idea on how to fix it I would be very happy. I was forced to remove the braking parts as it was the brake which "broke" and switch it with the clutch, the only way to make the clutch work is to push it as hard as you can to the right. Otherwise the clutches parts just hack and doesn't stick, kinda like a cogwheel that doesn't work properly.

    Thanks for your time.
    Last edited by a moderator: Jul 17, 2016
  2. Smasher4


    Hi mate, I think the problem is that the file permissions are bad, I think you should go to the installation folder and then right clic and select properties, then check permissions and uncheck read only, then apply...this solved me this problem in other games (i'm not having this issue in f1 2015), another thing you could do is to check if you have the game up to date to prevent any bugs... if this doesn't solve your problem feel free to ask I work repairing PC so maybe I can help.

    cheers from Venezuela and sorry if my english sounds weird (as my primary language is spanish), hope this solves your problem
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.