Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly rFactor 2 events

What racing gear do you use while sim racing?

  • Gloves

    Votes: 83 18.2%
  • Boots

    Votes: 20 4.4%
  • Gloves + Boots

    Votes: 41 9.0%
  • None

    Votes: 312 68.4%

Extremely high ping when racing online

Messages
3
Points
11
So basically, AC has always worked fine for me online. It was always playable and I had a ping between 10 and 40. However, for about a month now, I'm not able to get a ping under 300, even for servers in my own country (Germany). This sadly makes the game unplayable. I have not changed ISP or any devices that I use to connect to the internet. Are there any settings either in Windows or AC that I can try to use to lower my ping?

All answers are appreciated!
 
Messages
3
Points
11
I am not an expert here so.. if you run the Network Speed Test, what kind of ping do you see?
around 20-30. I've quickly opened AC to check and somehow my ping is now down to around 30 aswell. I usually don't play much this late and when I wrote the post I was checking in the morning for my ping. I'll keep an eye on whether my ping is better in the evening or not.
 
Messages
3
Points
11
around 20-30. I've quickly opened AC to check and somehow my ping is now down to around 30 aswell. I usually don't play much this late and when I wrote the post I was checking in the morning for my ping. I'll keep an eye on whether my ping is better in the evening or not.
please forget that, joined an online game and boom my ingame ping is back to 300-500

EDIT: I did a speedtest while AC was running in that same lobby with the same car and my connection goes from ~25ms/55mbps/25mbps without AC to ~1000ms/0.8mbps/0.6mbps. I only have this issue with AC so seems like the game itself is the issue.
 
Last edited:

Neilski

Staff
Premium
Messages
3,974
Solutions
2
Points
2,077
EDIT: I did a speedtest while AC was running in that same lobby with the same car and my connection goes from ~25ms/55mbps/25mbps without AC to ~1000ms/0.8mbps/0.6mbps. I only have this issue with AC so seems like the game itself is the issue.
Wow. Sounds like maybe your ISP has introduced some kind of traffic management system, which is malfunctioning. I'd have a word with them if I were you.
 
Top