Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly rFactor 2 events

What racing gear do you use while sim racing?

  • Gloves

    Votes: 168 19.6%
  • Boots

    Votes: 36 4.2%
  • Gloves + Boots

    Votes: 77 9.0%
  • None

    Votes: 577 67.2%

Error Message - CM Custom Shaders Patch

Rex Racer 65

Premium
Messages
45
Points
51
So, I've been getting an error message in CM/Settings/Custom Shaders Patch. I've tried redownloading, reinstalling, removing & reapplying and I can't fix this error. Please help!
Below is a clipboard copy of the error:

Navigation Failed
Source
/pages/settings/settingsShaderPatch.xaml


System.Windows.Markup.XamlParseException: The invocation of the constructor on type 'AcManager.Pages.Settings.SettingsShadersPatch' that matches the specified binding constraints threw an exception. ---> System.TypeInitializationException: The type initializer for 'ViewModel' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object.
at AcManager.Pages.Settings.SettingsShadersPatch.ViewModel..cctor()
--- End of inner exception stack trace ---
at AcManager.Pages.Settings.SettingsShadersPatch.ViewModel..ctor(Boolean isLive)
at AcManager.Pages.Settings.SettingsShadersPatch..ctor()
--- End of inner exception stack trace ---
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at System.Windows.Application.LoadBamlStreamWithSyncInfo(Stream stream, ParserContext pc)
at System.Windows.Application.LoadComponent(Uri resourceLocator, Boolean bSkipJournaledProperties)
at System.Windows.Application.LoadComponent(Uri resourceLocator)
at FirstFloor.ModernUI.Windows.DefaultContentLoader.<LoadContentAsync>d__0.MoveNext()
 
Messages
1
Points
0
has anyone came up with any solution for this one? I cant seem to find any solution no matter what I am trying to do..... this makes assetto corsa experience the worst.
 
Messages
358
Points
452
has anyone came up with any solution for this one? I cant seem to find any solution no matter what I am trying to do..... this makes assetto corsa experience the worst.

I had this issue, and it was my Sim Commander 4 software that I had setup to launch Content Manager for AC instead of AC directly. There were some numbers (can't remember what they were) in parameters that was causing the issues. Once I removed those I was golden. However, if you do not use Sim Commander/AF then not sure what is up as it worked for me after the change.

1601422813006.png


Edit: I also recall that this caused an issue while installing something through CM, so also had to go to the downloads area and clear that out. Make sure nothing is there, and that when you delete it, it stays deleted.

1601423203456.png
 
Last edited:
Messages
1
Points
11
I had this issue, and it was my Sim Commander 4 software that I had setup to launch Content Manager for AC instead of AC directly. There were some numbers (can't remember what they were) in parameters that was causing the issues. Once I removed those I was golden. However, if you do not use Sim Commander/AF then not sure what is up as it worked for me after the change.

View attachment 409472

Edit: I also recall that this caused an issue while installing something through CM, so also had to go to the downloads area and clear that out. Make sure nothing is there, and that when you delete it, it stays deleted.

View attachment 409475
Perfect, Thanks
 
Top