DTM 2015 - Black Screen

After a while away from the game I decided to get back into it and purchased the DTM Experience on Friday. Launched no problem. But over the weekend and up to now I have had all sorts of problems. Just launching the game has been a bit hit and, takes a while to load, every second time been asked to log in again etc. The main problem I am having however is launching the DTM Experience 2015. When I go to race I just get a black screen, with a pointer and occasionally a spinning circle. I have tried the other experiences, WTCC etc and generally can get them to launch. I can also get the DTM 2015 to launch under the normal RRE menu, i.e not through the Experience. Over the weekend I have also had the dreaded 503 error.

I have searched the official sector3 forum and noticed someone else has a similar issue. Have deleted the cache in my docs as some have suggested. I have also verified the integrity through steam countless times. A strange thing comes up everytime about having to install flash, but I am not sure this is related (I have Win8 if that helps).

So, anyone have a fix or reason this is occurring? My last option is to reinstall the game but I am loath to do that and having to do all my settings again. Thanks in advance.
Richard, mine seems to have fixed itself. After getting no replies I decided to delete & reinstall the game. However I suspect the problem & fix was due to the server issues they (Sector3) were having. I haven't had any problems this week. So the only suggestion I can make is a fresh reinstall. Good luck
I have the same problem, the only thing that worked out is to delete all files from
Documents\My Games\SimBin\RaceRoom Racing Experience\BrowserData\Cache
Top Bottom