Derek Speare Desing P1 and P2 not working with AC or ACC

DocFar

1RPM
Jan 21, 2017
9
2
55
Got the P1 and P2 button boxes and no matter what I do they are not seen by AC or ACC as separate button boxes - they map the same numbers so that you can really only use 1 box . Anybody got these to work with AC or ACC?
I have had no trouble running multiple other controllers on my PC and only have issues witht these two DSD boxes - they will not map separate (ie the numbers are repeated on the 2 boxes) even with everything else unplugged. Really appreciate some help if anyone got them working with AC and ACC PLEASE!!!!
 

AJ McDaddy

250RPM
Oct 20, 2014
363
129
51
Got the P1 and P2 button boxes and no matter what I do they are not seen by AC or ACC as separate button boxes - they map the same numbers so that you can really only use 1 box . Anybody got these to work with AC or ACC?
I have had no trouble running multiple other controllers on my PC and only have issues witht these two DSD boxes - they will not map separate (ie the numbers are repeated on the 2 boxes) even with everything else unplugged. Really appreciate some help if anyone got them working with AC and ACC PLEASE!!!!
I have this problem in ACC, I've not figured out how to get it working yet, so have ended up configuring auto-wiper/pit limiter/lights etc, but with the latest ACC server update admins can disable those features.

Watching this thread in anticipation, but might be worth posting on the ACC forum over at Kunos.

BTW. I didn't have this issue in AC when using content manager.
 

DocFar

1RPM
Jan 21, 2017
9
2
55
Checked the link and I am on the board but for some reason but cannot post a reply. I do have a work around ..use JoyToKey to change the button box output to a keyboard binding eg switch 6-box 1 is Shift L and then map this in ACC, switch 6-box 2 is Alt T and map this in ACC. Voila! 2 button boxes though a bit more mucking around. DSD says they work perfectly for everyone - well I think there is a problem/conflict/bug with the boxes when using a Fanatec DD base. I can plug in any other same brand controllers and they get identified correctly.
 

AJ McDaddy

250RPM
Oct 20, 2014
363
129
51
Interesting - I'm using a Fanatec CSW 2.5, so it might be the Fanatec controller software.

Will look into your workaround as I'm already using JoyToKey to map the Home key on my rims to centre TrackIR. Thanks for the heads up.