• 27500+ Members! Dear Guest, click this link to join the community on the official RaceDepartment Discord server

Dedicated Server: Geometry and TDF mismatches?

Feb 15, 2014
Heyas, having issues setting up my Dedicated Server with Enduracers + Simtek addon.

Short Version:
Only the first track in the server rotation works. Going to the next tracks in rotation gives everyone who connects a "Track Geometry" and "(track).tdf" mismatches, where (track) is whatever the first track in the rotation is.

Long Version:
I rent a server from purepings and update/modify it via FileZilla. My normal means of modifying the Multiplayer.ini, Dedicated(mod).ini, and plr files is to run the rfactor dedicated server program, set it up how I want the dedicated server set up, then close it and upload the generated ini and plr files to my dedicated server. This method has previously worked just fine for CARTfactor and various dirt track mods I've run.

Unfortunately now I'm having issues with Enduracers. Basically only the first track in the rotation works, additional tracks throw the previous errors. For example, the first time it happened I had Donington GP as the first track in the rotation and Fuji 1993 as the second. Donington worked fine, but when we finished the weekend and the server rotated to Fuji, everyone got a "Track Geometry" mismatch, and a "Donington.tdf" mismatch. I thought maybe just that track was bad, so I switched the track rotation to have Phillip Island first and Mid-Ohio second. Same thing, Phillip Island worked fine, but when we switched to Mid-Ohio, we got "Track Geometry" and "phil.tdf" mismatches. I thought maybe previous mods had messed with some core files, so I reinstalled rfactor on the dedicated server and reinstalled the mods, same issue. I also verified that the tracks I had on the server were the same as the ones myself and my friends were connecting to.

Basically what I think is happening is the server switches tracks, but still looks for the first track file when checking for matches and doesn't find it from anybody, EVEN THOUGH the server itseld has switched tracks So what's going on? I've tried looking through the Multiplayer.ini and DedicatedEnduranceSeries.ini files to see if any configuration issues are to blame, but I can't find anything. Please help?