Controls stop working

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
If I change wheel and pedal settings and save them under my own profile, quite often the wheel becomes unresponsive.The bar indicators showing pedals axis input don't show anything.Sometimes its just changing car setup files within a race and I don't realise the wheel has stopped working until I exit the pits. The last time it did it (a moment ago) I was resetting the event as I always start last despite qualifying first.

Wheel Driving Force GT
Profiler 100% FFB No centre steering, Separate pedal axis, 900 degress

Please can you help me identify the issue as its getting so frustrating
 

Paul Bennett

2000RPM
Sep 16, 2012
2,130
896
I have the DFGT some times feels a little unresponsive, I always start the wheel first then open game. I have my settings saved and don't normally change them, only wheel lock in game for the car.
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
I have the DFGT some times feels a little unresponsive, I always start the wheel first then open game. I have my settings saved and don't normally change them, only wheel lock in game for the car.
I do the same, but the loss of control is out of my hands and I mean loss of control. It totally stops working. As I said earlier, it can happen when I make simple adjustments to the car, or the main menu options (such as AI difficulty)

Is this a common bug, or is something wrong between my game, my OS (win 8.1), and my Logitech profiler? I don't have this issue with AC or pCars, if I did I would have investigated driver issues.
Thankfully I don't have this issue elsewhere or I would be very saddened
 

Msportdan

@Simberia
Mar 17, 2014
2,962
564
42
yep I get this....

just had it this very moment restarting the game workls.. But you can no longer do changes to options mid game/race
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
yep I get this....

just had it this very moment restarting the game workls.. But you can no longer do changes to options mid game/race
Restarting the game works for me too, but thats not really a solution. Especially when restarting (losing any changes you may have made) it can happen instantly you alter something, or just by simply loading the next race.Its that unpredictable.
 

bömii

500RPM
May 28, 2013
853
232
32
i had this earlier today, pedal input was registered, but no wheel input. restarting everything didnt help, i loaded another controller profile and it worked again. no again what happened
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
Well its good (and not so good) that its not just my experience being ruined as others are having the same issue as I am.

However, I come here to ask for a help to the problem. I adore this game. I really do. I get goosebumps when I hear the in cockpit sounds of the V8s and the recently added touring cars (the ones similar to BTCC) I forget the actual series name.

I would love to play the game without issue. Its remarkable what Reiza have achieved on such an old game engine and the free content is nothing short of amazing. Please keep being awesome.


But I need help.
 

Paul Bennett

2000RPM
Sep 16, 2012
2,130
896
As there is no pre-set for the DFGT this could be the issue. I have a combo of DFGT wheel with G25 pedals & G27 shifter using the Bodnar attachments so all custom for me
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
I am custom too. When setting up the wheel all axis that i need, and the buttons I wish to use are acknowledged by the game perfectly well. When I don't have issues, I race just fine. Then out of nowhere, it just stops working. Sometimes it will work for the whole session I am playing.Other times it stops If I change something or load a race in my career/championship.
 

morsify

1000RPM
Premium
Jun 26, 2009
1,953
767
A year or so ago, I had a similar problem with my G27 and this game. The controls would stop working in the middle of the game, often while driving. Control returned a few seconds later but by then it was too late, I had crashed.
I plugged my wheel directly into a usb on my pc (i.e. do not use a usb hub), and this fixed it for me. Even if yours is already plugged into the main pc unit, it is worth trying a different slot, it might have a more stable power flow. Also, if you have any un-needed peripherals, remove them all as an experiment to see if it fixes it.
May not be the same problem but I hope that helps in some way.
 

Derek Lundie

25RPM
Apr 18, 2014
32
39
This is a problem across multiple brands as I have had the same problems with my Thrustmaster TX. Like others have said it seems to happen most when I try and edit wheel settings while in the race weekend. Restarting the game fixes the problem but it is frustrating, I have had to forfeit a couple of offline championship races due to this problem in both Stock Car Extreme and Formula Truck
 

Renato Simioni

Reiza Studios
Jan 6, 2010
1,649
5,246
Just so we have a better understanding of the problem, as we haven´t been able to replicate yet and reports here point in different directions: the problem is losing controller configuration, triggered by changing controller settings in-session? Or can you also lose it without changing anything? Any extra info that could help us stablish the pattern is helpful.

Also, can the people having trouble recall always having it with their current devices in GSC, or did it start after one of the updates?
 
  • Like
Reactions: Andrew

Derek Lundie

25RPM
Apr 18, 2014
32
39
In my case all of the bindings stay the same, but the game stops detecting the inputs. And yes this only seems to happen when changing controller settings in session, I haven't noticed it when changing other settings like the others above. Backing out into the main menu doesn't solve it so a full restart is required. I'm running the steam version on Windows 8.1 with a Thrustmaster TX + TH8A + DSD Track Boss setup.

By the way thank you very much for the amazingly quick response :)
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
Its happened to me since I bought the game some time ago, I reported the issue on the Steam forum but it didnt get seen by many (http://steamcommunity.com/app/273840/discussions/0/610574394235548366/)

When it will fail. Going into the control settings,and trying to map the buttons, or map more buttons once you realise there are more functions that can be useful to you mid race. It seems to kill the wheel if done at race within the garage. Another time it can kill the wheel is restarting a session or whole event (go back to practise 1) Once you then go back out your wheel no longer works. This is intermittent as sometimes the wheel will be OK for a whole play session (if I dont alter anything)

I use USB 2.0 ports. I have 3 devices attached to my motherboard. Mouse Keyboard and a Logitech Driving force GT.

I have to restart the game for the wheel to respond again. I use Windows 8.1

 
Last edited:

Anestis

100RPM
Oct 1, 2009
208
70
It's happening to me even before gsce went to steam, but let's say 2-3 times out of 10 (I though it was from my side).
I couldn't find a way to replicate it, it's random and it's happening only when I am in controls and ffb settings. The only fix is to exit and restart the game. Not a big deal as I'm used to it by now(I never touch the controls when I'm in an online session)
I use 3 game controllers : t500, a Pic diy (pedals, h-shifter, button box) and edtracker.
Win 8.1 x64, all my racing peripherals are on usb2
I'm not complaining, the only reason I report it is to collect Reiza some reports of the problem :)
 

Scott Tanner

3vil - Steam
Jan 5, 2010
345
60
I wonder if this is a Win 8.1 issue. Can those that are experiencing the issue please state your OS