Content Manager Installation

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
Hello All, I have just installed the full version and have it on my desktop.

I am getting an error message Error :- No such interface supported - More Information in log.log.

Can anyone assist me ?

I have checked for error signs against mods and removed those.

Cheers

Chic
 

dhmotor

100RPM
Premium
Apr 28, 2017
206
142
You need to put CM.exe in your AC root folder. Just put the shortcut on you desktop; CM and all of its files need to be in the AC folder. Maybe you've already done that, not sure from your description.

Edited to clarify the .exe for CM should be in the root folder.
 
Last edited:

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
I have now put it in the AC root folder along with a shortcut to desktop. It is trying but still keeps coming up with the same error message.

Also How do I join SRS Races.
I can Register for a race but where do I join it.

Sorry Bit of a Newbie here.

Chic
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
Personally, Content Manager is not installed in AC root folder, it may be installed anywhere.
Maybe the desktop should be avoided except a shortcut to launch it.

Content Manager just needs to know where your AC root folder is on your PC.
Therefore, ....
- open Content Manager
- go to Settings tab above at the right
- select Content Manager above at the left
- select General in the list at the left
- find the Assetto Corsa folder ... and it has to be something like that: ....\Steam\steamapps\common\assettocorsa

I don't remember if it needs to be "Saved" .... as now I just have a "Change" or a "Open". ;)

For the SRS, sorry I don't know as I'm only driving in leagues.
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
I don't need to do it .... but who knows ?: could you try launching Content Manager with Administrator Rights ?

If this is not the problem ...
Now where is this log.log ? .... What concerns AC Manager is in the Users/User/Appdata/Local/AcTools Content Manager and there's a Logs folder with such log names: "Main Log_190224_154536.log"

I suppose that's this log which is meant there in this message.

If you find it, could you zip it and send it here ?
 

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
Ok I have located the Log.log
Also
errors Log
launcher Log
launcher_controllers
launcher de_bug
py_log

Which of those do you require and where should i Send them ?
I appreciate your assistance.

Chic
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
Could you be more precise when you say:

I am getting an error message Error :- No such interface supported - More Information in log.log.

Does this happen when you launch Content Manager ?
Or does it happen at another moment ? ... for example when trying to launch a private event ? or entering a server ?

Is this a content manager problem ? a AC problem or a Shader Light Patch problem ?
With more precisions it should maybe be easier to find the reason of your problem. ;)
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
That's what I suspected ... so I'll have a better look on your log ( maybe someone else might do the same ) ;)
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
Please try with another car .... I think you have a problem with the Ginetta mod.

I launched the same race as yours and that's what you get ... that I don't:

ERROR: Material::getVar CANT FIND VAR normalLevel for shader g55_tyre
ERROR: Material::getVar CANT FIND VAR groundNormal for shader g55_tyre

Try with an original car so that we may be sure of this error....
If it's working with another car ..... we'll be sure that everything's fine for your install.
 

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
I really thought we were on to something there but I have just tried a ks Car and ks track but still got an error message.

It may be I will have to delete all cars and tracks bar ks ones to see if that would work.
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,931
587
69
You'd better check your game, Charles ..... there are missing or corrupted files in original cars

I didn't look at all but already found FMOD problems ( sounds ) for the Alfa Romeo GTA and Ford Escort MK1 ....

I guess there are maybe more problems in other cars.

Nothing can be done except by yourself for mod cars but for the original ones, check game files integrity in Steam.
I suppose you know how ? .... but, just in case you shouldn't know:
- Open Steam and your games list
- right-click Assetto Corsa and choose "Properties"
- tab "Local Files"
- click on "Check game files integrity" .... something like that anyway, my Steam is in french

Your game files will be checked .... and missing or corrupted files will be downloaded and reinstalled at the end of the process.
 

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
I have just reinstalled Assetto Corsa and validated all files and reinstalled CM and still have the same outcome. I will work away at this for a while but if I am getting nowhere with CM i guess I will just have to ditch it.
 

Charles Soutar

10RPM
Original poster
Mar 14, 2015
14
0
64
Tyvm for your assistance Jempy but I think I have a registry problem and I am now going down that route Thx