Caution....Thrustmaster firmware 46

Discussion in 'Sim Racing Hardware' started by Terry Rock, Oct 29, 2017.

  1. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    If you currently own the T500RS or even the T300 and have not yet done the latest driver and firmware update, you may want to delay doing so.
    My T500RS steering wheel (with Ferrari GTE rim add-on) has been faultless since the start of ownership.
    It has been functioning without a single hiccup on driver 4.TTRS.2016 (firmware 43) driver 2.9.1.0 prior to installing the new package 6.TTRS.2017 (firmware 46) and driver 2.10.6.0.
    After a 'clean' install of the new driver and firmware, only the original chrome, static paddles are working correctly.
    Neither one of the paddle shifters on the GTE rim and only a select few buttons on that wheel rim, respond in the TM Control Panel.
    I am running Windows 10-64 version 1709 Creator edition (Build 16299.19). with all drivers throughout the computer up to date.
    My previous driver package was removed using the add/remove feature in Windows.
    The wheel had been left unplugged prior to starting the PC initially, in anticipation of the older driver removal.
    The PC was then restarted and the newer Thrustmaster driver package installed...with the wheel reconnected only on request.
    The firmware update was initiated after the restart on completing the driver install.
    The firmware process was reported as successfully completed with all three green check boxes accepted.
    I've submitted a report to Thrustmaster and will update the findings.
     
    Last edited: Oct 29, 2017
    • Like Like x 1
  2. MegamanAT

    MegamanAT
    Premium

    Messages:
    240
    Ratings:
    +111
    I can confirm issues too. T500 with custom wheel and arduino. only 2 buttons working after upgrade to v46. no issues with v43. but the t500rs wheel is working fine.
     
    • Agree Agree x 1
  3. Andy_J

    Andy_J
    PC Veteran Gamer and Biker. Premium

    Messages:
    7,287
    Ratings:
    +3,408
    edit: mine is also playing up.:cautious:
    I have gone back to v43 for my T500.
     
    Last edited: Oct 30, 2017
  4. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    It's a bit disappointing that TM would put this software out there.
    I bought that GTE wheel rim because I struggle with static paddles.
    I've now pulled that unit and fortunately, still had the original T500 rim in a closet.
    It confirms what I already knew....bad firmware from TM.
     
  5. Matt88

    Matt88

    Messages:
    147
    Ratings:
    +60
    No issue's here with a T300 using both GTE and Ferrari F1 Rim.

    In fact working better than ever!!!
     
  6. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    Good to hear you are not having any issues.
    On reading the firmware notes, it looked to offer a few good improvements.
    That's the only reason I went with the update, so it is a bit disappointing how it turned out.
    What version of Windows are you using?
    The problem may be limited to only the T500 wheel as well.
    I've now come across four instances of the exact symptoms on scouring various post...all T500...all after doing the firmware 46 update.
    The D-pad inputs are reversed as well, in addition to the other problems.
     
  7. Mick Aspinall

    Mick Aspinall
    Premium

    Messages:
    274
    Ratings:
    +65
    Thanks for warning, will wait till update has a update:thumbsup:
     
  8. Rupe Wilson

    Rupe Wilson
    rFactor Senior Club Manager Staff Premium

    Messages:
    16,841
    Ratings:
    +6,942
    ok thanks for the heads up... i nearly updated my wheel.. luckily they can be rolled back/deleted and the previous one reinstalled if needed :)

    Here is version 2016_TTRS_4 if anybody wants it or needs it.. i use this on my t500rs.
    from there you can update to 5 i think.. i will not be touching it until i hear its ok

    Edit
    i dont think the version i posted has the option to downgrade the firmware. so please go with the option from Terry :thumbsup:
     
    Last edited: Nov 2, 2017
    • Like Like x 3
  9. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    I can now confirm that firmware 46 was 100% responsible for the loss of function on my GTE rim.
    This evening TM's customer support sent me a link to the 2017_TTRS_3 package, which I promptly installed.
    That package gave me the option to downgrade firmware... (which I did not think was possible).
    I am back on FW43 with driver 2.9.71.0.
    Full function is restored.

    Edit:
    After testing 2017_TTRS_3 , I completely removed that package and updated the driver only to 2.10.6.0 using 2017_TTRS_6 package...no firmware.
    Operation is still normal, which confirms the firmware definitely was at fault in my case.
     
    Last edited: Nov 2, 2017
    • Like Like x 2
  10. Rupe Wilson

    Rupe Wilson
    rFactor Senior Club Manager Staff Premium

    Messages:
    16,841
    Ratings:
    +6,942
    after purchasing the sparco 383 mod wheel im now left with a problem.. to get this wheel to work with its paddles and all its buttons with a multinational d pad in need to use 2017_TTRS_6 package and the firmware version v46
    but as we know with the t500 using the above means the Ferrari 458 wheel looses its paddles and buttons..
    if i go back to the old firmware and drivers the Ferrari wheel works again but the sparco wheel stops...

    they do seem rather helpful and responded the next day when i submitted a ticket. the only problem was the solution the suggested was the same as what they told Terry.... so i replied with the findings and they are going to get back to me... i tried all different combinations and none of them got it all working together...

    i hope they sort this out soon..
     
  11. DrRob

    DrRob

    Messages:
    34
    Ratings:
    +19
    I recently installed the Sparco 383mod on my T500RS wheel base and updated firmware without probs so far. All buttons and shifters working *fingerscrossed*.
     
    • Like Like x 1
  12. Rupe Wilson

    Rupe Wilson
    rFactor Senior Club Manager Staff Premium

    Messages:
    16,841
    Ratings:
    +6,942
    it appears the older rims don't like the new firmware needed for the newer rims...

    but as far as the Sparco 383mod goes its really nice, i have to admit..:)
     
    • Agree Agree x 1
  13. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    Agree.
    If you look at the TM Control panel after the firmware update, you'll notice the pictorial represented wheel list a whole lot more buttons....so I think the newer wheel rim was the priority.
    The TM representative said they be putting out a new update.
    Hopefully, we can then benefit from some of the improvements listed in F/W 46.
     
    • Like Like x 1
  14. Rupe Wilson

    Rupe Wilson
    rFactor Senior Club Manager Staff Premium

    Messages:
    16,841
    Ratings:
    +6,942
    Just had a reply back from thrustmaster about my wheel issues..

    They are working on a new driver to solve this problem,
    And at present to use both wheels, it will require a change of driver/firmware...

    This will be solved shortly with a new driver.
     
    • Like Like x 3
  15. TylerDurden4321

    TylerDurden4321

    Messages:
    97
    Ratings:
    +63
    Holy **** guys! I just wanted to sell my GTE rim on eBay and had problems with the D-Pad left direction (only 2 out of ~3 presses were recognized), opened the GTE wheel, turned the soft pads of the d-pad a little so it would feel correct again and re-assembled the rim again.
    Put it on my T500, connected and pressing to the left now was UP... I was so ****ing shocked! xD
    Connected my 599xx rim and that worked flawlessly, DOUBLE shocked.

    Thrustmaster really should put a note on the new firmware that older wheel rims make trouble.
    Thanks for making this thread, OP. I would have probably dis- and re-assembled the rim 3 more times without this thread.
     
    • Agree Agree x 1
  16. Anestis

    Anestis

    Messages:
    206
    Ratings:
    +65
    Package 2017_TTRS_7 is up including T500 RS: Firmware V47 & T300 V28 and more.
    I haven't tried myself yet
     
    • Like Like x 3
  17. Rami

    Rami
    #20 FinnTeam Premium

    Messages:
    387
    Ratings:
    +172
    Anyone tested the new fw yet?
     
  18. Terry Rock

    Terry Rock

    Messages:
    1,363
    Ratings:
    +469
    I can now confirm that this update works for the T500RS with GTE rim.
    It takes you to driver 2.10.9.0 (F/W 47).
    I installed it tonight and ran both RRE and a few laps with AC.
    No issues to report.
     
    • Love Love x 1
  19. Rami

    Rami
    #20 FinnTeam Premium

    Messages:
    387
    Ratings:
    +172
    Thanks for the confirmation :thumbsup:
     
  20. Anestis

    Anestis

    Messages:
    206
    Ratings:
    +65
    In my case trying to install the newest driver (no firmware) my T500 couldn't calibrate, it was constantly moving left to right and even my other peripherals like keyboard, mouse etc went crazy and not working with their leds blinking, until a system restart.
    I tried different usb ports, tried with the f1 wheel same result. At one point I thought my wheel or my motherboard was dying.
    Then I went back to 2017_TTRS_6 and it's back to normal.
    Maybe is something wrong from my side but I never had any issue before.