Cars Car mods not working, crash back to main menu

Rotjone

1RPM
Oct 14, 2019
6
0
26
So i've been struggling a couple days with this problem, some car mods wont work (some will just fine). I have reinstalled the game twice now, once to HDD and now to SSD but the problem is still there. When trying to go to track the game throws me back to main menu when trying to load the car. Sometimes it has a message like in the picture, sometimes it just says Race Cancelled. The cars that i can't get to work are Legends car mod (ford 34 coupe), Alfa Romeo GTAM and BMW E36 JUDD, and there are probably more that wont work but haven't yet tested. I'm pretty clueless what to do next as i have a clean install of the game and install the mods in the right folder (and some mods work just fine). Also if i remember correctly, all of the cars above i have had working earlier, they just don't work anymore. I have the latest updates of them.
Sieppaa.png

Please help.
 

AccAkut

2000RPM
Premium
Mar 21, 2015
2,326
2,001
So i've been struggling a couple days with this problem, some car mods wont work (some will just fine). I have reinstalled the game twice now, once to HDD and now to SSD but the problem is still there. When trying to go to track the game throws me back to main menu when trying to load the car. Sometimes it has a message like in the picture, sometimes it just says Race Cancelled. The cars that i can't get to work are Legends car mod (ford 34 coupe), Alfa Romeo GTAM and BMW E36 JUDD, and there are probably more that wont work but haven't yet tested. I'm pretty clueless what to do next as i have a clean install of the game and install the mods in the right folder (and some mods work just fine). Also if i remember correctly, all of the cars above i have had working earlier, they just don't work anymore. I have the latest updates of them.View attachment 342513
Please help.
any log files to tell use where exactly the game crashes in the loading?
 

Ghoults

1000RPM
Mar 30, 2009
1,236
854
Go to your C:\Users\username\Documents\Assetto Corsa\logs and see if you see anything odd in log.txt towards the bottom before the meltdown error. Is it the same track. Can you post screenshot of the car folder
 

Rotjone

1RPM
Oct 14, 2019
6
0
26
Okay so the car was Alfa Romeo GTAM at ks_highlands and this was at the bottom of the log:

CRASH in:
OS-Version: 6.2.9200 () 0x300-0x1
d:\dev\dev_pc_master_race\acs\caravatar.cpp (1309): CarAvatar::initPhysics
d:\dev\dev_pc_master_race\acs\caravatar.cpp (896): CarAvatar::CarAvatar
d:\dev\dev_pc_master_race\acs\sim.cpp (1446): Sim::addCar
d:\dev\dev_pc_master_race\acs\racemanager.cpp (462): RaceManager::initOffline
d:\dev\dev_pc_master_race\acs\racemanager.cpp (174): RaceManager::loadSessions
d:\dev\dev_pc_master_race\acs\sim.cpp (320): Sim::Sim
d:\dev\dev_pc_master_race\acs\splashscreen.cpp (319): SplashScreen::postRender
d:\dev\dev_pc_master_race\ksgame\game.cpp (181): Game::onIdle
d:\dev\dev_pc_master_race\ksgame\game.cpp (210): Game::run
d:\dev\dev_pc_master_race\acs\acs.cpp (477): wWinMain
f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c (618): __tmainCRTStartup
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF989A47BD4)
00007FF989A47BD4 (KERNEL32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FF98B2ECED1)
00007FF98B2ECED1 (ntdll): (filename not available): RtlUserThreadStart

And here is my cars folder:
cars.PNG
 

Ghoults

1000RPM
Mar 30, 2009
1,236
854
The important bit is couple of lines up before the ERROR part. Also a screenshot of the car folder, not the cars folder. Just so people can see if the folder structure is ok inside the car folder.
 

Mahad

500RPM
Oct 24, 2015
748
609
Tried the car and all is working fine (CSP + SOL no CM). What does your launcher.txt say ?
 

Rotjone

1RPM
Oct 14, 2019
6
0
26
Okay so i did some digging and found out that some of the mods needs DLCs installed and i have just the base game. Link to the discussion:
 

Rotjone

1RPM
Oct 14, 2019
6
0
26
what does it need for this to work? thank you
Like said, some of the modded cars might use files from the DLCs so if you only have vanilla game and the car doesn't work, it's most likely that you need some DLC installed.