Can't get Sim Commander to launch games in VR

Eyeon

1RPM
Jun 20, 2017
4
1
39
Resolved see final post.

Just picked up a Buttkicker and decided to buy Sim Vibe as well. I tried it without Sim Vibe using the audio split and it was terrible. Just a muddled mess of noise and vibrations that made me question my purchase. Hopefully I can get Sim Vibe working as all the posts I've read said tactile feedback is a worthwhile investment.

Anyhow the issue is if I have Steam VR open and I use Sim Commander to launch the game it just hangs and won't launch. If I DON'T have Steam VR open and I use Sim Commander to launch the game, the game opens fine and Sim Vibe works great. I have no desire to race on a monitor though.

I assume this is due to the popup that occurs when launching a game with VR where it gives you 3 options: Play, Play in Steam VR, Play in Oculus VR and Sim Vibe doesn't know how to handle this.

Things I have tried. Setting Sim Commander to monitor for the game to launch and then manually launching the game through Steam. Tested PC2 and DR2, no luck, both games launch but Sim Vibe doesn't work. I also tried modifying the launch parameters to steam://launch/690790/steamvr -silent and steam://launch/378860/steamvr -silent respectively for each title. Still no luck. Is there some other parameters I should be using? I tried Googling extensively for this issue and couldn't find much.

I am sure there are people using Sim Commander with VR, how are you guys launching the games? What am I doing wrong? Thanks in advance.
 
Last edited:

Eyeon

1RPM
Jun 20, 2017
4
1
39
Tried the parameters steam://launch/378860/othervr -silent that someone suggested on Reddit. Apparently this works for Oculus users but it doesn't work for me using Steam VR headsets. Just get waiting for game to start in Sim Commander and launching status in Steam. See screenshot below:
 

Attachments

Last edited:

Jeremy Ford

500RPM
Premium
Apr 28, 2016
630
355
You can set SimVibe to not automatically launch games, and it will sit and wait for you to manually load the game. That's the way to circumvent this. Sorry, it's a been a while since I used SimVibe, so I can't direct you to the exact setting, but that's the solution to get around this.
 

Eyeon

1RPM
Jun 20, 2017
4
1
39
Hey Jeremy thanks for the reply. I have that option checked but Sim Commander still doesn't work even when launching the game manually.

Is there a better software to be using? I might ask for a refund if I can't get it working in VR.
 

Eyeon

1RPM
Jun 20, 2017
4
1
39
After contacting support I got Dirt Rally 2 working in VR with Sim Vibe. For anyone else who sees this here is what you have to do. Go to Documents > My Games > Dirt Rally 2 > hardwaresettings. In that folder there is a file called hardware_settings_config_vr.xml. Edit that file in notepad and in the motion platform section add the line: <custom_udp enabled="true" ip="127.0.0.1" port="10001" filename="SimXperience_Dirt_V1.xml" delay="1" />

Then to play the game first launch Sim Commander. Then launch Steam VR, launch the game in Steam, play in Steam VR. Then go into Sim Commander and double click the Dirt Rally 2 icon and it should say game is running and Sim Vibe should be working.

Also in order to get Project Cars 2 working you need to go to in game to Options > System > Shared Memory and set it to Project Cars 2. Then to play it the steps are similar to Dirt Rally 2. Start Sim Commander, start Project Cars 2 in VR, then click the icon in Sim Commander so it says game is running and SimVibe should start working.

Andrew thanks for the link I might give that launch parameter a try and see if I can save a step having to alt tab out and click the icon in Sim Commander.

Edit: yea the launch parameters work great, thanks Andrew.

So to anyone else who finds this change the launch parameters as listed in that thread he posted. So for Dirt Rally 2 it will be steam://launch/690790/vr and then you can launch the game directly from Sim Commander and it works.
 
Last edited:
  • Like
Reactions: Andrew_WOT