Can't Export...Help Please

Discussion in 'Bob's Track Builder' started by moeom, Jul 3, 2011.

  1. moeom


    Hey guys, so im working on a track at the moment. But now that i want to export the track for some testing, its giving me an error.

    BTB is telling me: 'Can't export Object reference not set to an instance of an object.'

    Has anyone had that problem before? Its the first time i get the message. So i was wondering what i will have to do. I was thinking that once i get back to working on the track tomorrow, to delete all the objects that i 'think' will stop the problem and see what i can deduce. But i was just throwing the question out there for anyone that knows what should be done while keeping the objects i want to keep.

    Thanks in advance.
  2. Pangaea


    probably on of the most common errors ull encounter with btb, get used to it :)

    i cant remember exactly what the various solutions are but I think its got to do something about material conflicts, and yes the error usually comes up when dealing with imported objects and/or changing textures in the materials editor in btb.
    I would suggest you perhaps make a new 3d object and name the materials something new.. try that. perhaps you can get back to an earlier stage with the venue files?

    Since this is a common enough problem, im sure other people will give you suggestions on what went wrong and how to fix it

    best of luck
  3. mianiak


    AIW can cause this sometimes. Try moving the pit path to the opposite side of the track. Make sure to save a backup first. See if it works, if it does, then you would need to remove the aiw and start again with it.
  4. p00se2


    encountered this a few times now

    it was related to xpacks - one time i deleted objects i put on my track (xpack was NOT in use anymore - so i unchecked the xpack to unload it ) tried to export and got that error - reticked the checkbox for the xpack i just removed and it worked fine

    in most other instances i could fix that error by removing all objects but that overkill when doing actual track production

    what i do now is : NOT use any xpacks that cause that error

    what you can try :
    backup your track -delete all objects - export
    add your xpacks - randomize and fill your terrain with all objects (spam around dont spend time on this ) - export - if you get any error now dont use that particular xpack
    trial and error

    hope you get it sorted
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.