• We are currently in the process of upgrading our forum software. During this period some parts of the site may be periodically unavailable.

Bug report problem joining multiplayer

I'm not sure if this is the write place to post this but the in-gameish report system does not work for me so i'm going to report here and maybe someone can enlighten me to my issue.
First congratulations on the multiplayer. as someone from New Zealand who plays with 300-400 average ping and random cutouts my experience so far has been one of the most close, lag free simracing experiences I'v ever had actully better than asseto corca and other next gen Sims (I have yet to play iracing and never intend to).

Now my issue: I often have found when I try to connect to a server i get to the livery choice screen but am unable to pass it. this happens most of the time but sometimes (randomly as far as i can tell) i get into the race and have a thoroughly good time.
I think its about timing out of server or ending seesion, or someone else who was quicker and joins to server faster than U :D

Shannon Flynn

When in doubt, pass out.
I THINK I ran across a bug.

I tried many times to join the Get Real Bathurst GT Classics server.
Selected the BMW 3, then livery, the game didn't connect to the game server.
BMW 6, same deal.
Later tried the Volvo, and the game went straight to the server as it should.

Tried both of the BMWs again, without luck.
Tried the Volvo again, worked fine....

Twilight Zone?

Also, the server was in Practice Session with plenty of time remaining. So it wasn't a session switch server timeout or anything
in some cases Id noticed that time of qualification does not reflects correct. For example, session is on, but the time is already out. :cautious:

Shannon Flynn

When in doubt, pass out.
Regarding the issue I had joining the Touring Classics server using a BMW --

I jumped in a race last night with my trusty Volvo, and there were a couple of people driving BMW's. So, I guess it's a non-issue
I have had the same problem...Procar..I have 2 liveries.....cant get past livery choice screen...same with a Radical Judd...have tried a number of empty lobbies with same problem....no problems with RUF for some reason or free content ( Aquila and race room raceway. I just did a successful race at Laguna in the RUF after failing to enter another with Procar..
Got into a Procar/Zolder ( good racing...no squids!) race last night, but got the freeze when trying a Zakspeed ( G5?) race although the lobby was empty.
Last night, I tried a number of different races with plenty of spaces, including the free content and got into none. Finally, I picked a Zolder/Zakspeed combo...my 2nd livery did not work, but upon choosing the default, I got into the practise session. I am enjoying the MP (alpha), but this is a regular problem for me. Server lag?