Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

Big Stutterings VR - RTX 3080

Hi guys,

POSSIBLE FIX FEW POSTS BELOW

The issue is:
During the gameplay, (practice, hotlap, etc etc) when I start the session, after few laps, it starts to give me a big stutterings, mainly after few drifs or when I run out of the road and go back. If I start the session and imediately start to drifting and creat a lot of smokes the stuttering issues do not come, it comes after a while. It looks like the CPU acomulated a lot of "physics" and in a momement it start to bound and stuttering comes. It so annoying and I cant play happy anymore even with highend computer lol

(CHECK PICTURES)

AC-Issue-vini.jpg


I'm running on:
Z490 Asus with latest BIOS
i9 10900f
32gb 3200mhz c16
RTX 3080 Strix
512gb nvme m2 with at least 100gb free
HP Reverb G1
Windows 10 Pro 21H1 with all updates

Shaders Patch 0.1.75-preview1
ID 1555
Sol 2.1
Steam VR Supersampling 150% which is around 2600x2600px per eye (even with this my GPU usage is around 75%, so I have headroom here)

Things I tried without success
- Downsampling Steam VR to 40% to have a lot of headroom (the stutterings is less notable but it still there on the blue line and the yellow line)
- there is no ASW or motion bla bla on VR.. disabled on wmr too
- Absolutly NO thermal throttling
- Disable SOL
- Disable WheaterFX, Particles, Rain, Skidmark FX, Lighting FX, SmartShadows, Refletions, Graphic Adjustments, extra FX, Smart Mirror, Track Adjustments etc etc...
- Disable vanilla smoke and skidmarks
- Disable complete CSP
- Reset General Patch Settings
- Tried all ooptions of optimizations of CSP on and off
- Reinstall Shaders Patch
- Install old versions of Shaders Patch
- Reinstal AC complete
- Reinstal Windows 10 complete
- Rollback Nvidia Drivers to few versions old
- Reinstal audio drives with latest versions
- SteamVr and WMR betas and non beta version
- disable my T300rs and play with keyboard
- compress files with CM tool
- OC my DDR4 to 4000mhz stable
- Underclock my DDR4 to 2666mhz
- FTH trick on regedit
- Disable BAR on bios
- change nvidia panel to highperformance
- change windows power plan to high performance and balanced (also power saver)
- run script to debloatware my Win10
- no antivirus is running
- Win10 GPU scheduling ON and OFF
- With Rivatuner and Afterburner off, the problem persist
- The issue is not notable with single screen play
- Disable windows Antimalware services on regedit

This issue not happens with AMS2, PC2, Rfactor and other non vr games. Only in AC
 
Last edited:
I've had stuttering with my 3060ti , rolled back to the driver 461.09 and it resolved my problem.

I tried and it didn't work, thanks.

Does the issue go away if running in Windowed mode?

Windowed mode and also tried the alt-enter trick. No results.

Your fan RPM doesnt look right, unless you set it manually to full speed? doubt its throttling, looking at the gpu temp but just looks odd on your screenshot.

I was pushing the gas, that's why the high RPM.


..

See the blue line (cpu) above the yellow line (gpu).
When I start the session, even when the car is stopped at Pit, initially the blue line is perfect flat, so after few seconds like 10 (even without moving the car), the blue line starts to get a lot of little spikes and its not flat anymore. In this moment the game is playable without stutterings, the stutterings occurs when the it exige physics.. so it does a cpu bound and stutters come.

What I mean is somehow looks like the CPU is overloaded with another process causing the little spikes on the blue line, and when AC needs all cpu performance it fails and stuttering comes.

I suspected it is caused by another app, like antivirus, or windows doing something in background. (or even the AC) I cleaned my Win10, forcing disable the antimalware service executable etc etc.. without success.

Maybe is a issue with Win10 + i9 10900f and AC.. I really don't know, there is 10 cores and maybe the AC is "lost" how to dealing with this.

I'll try one more thing now, to move AC to a HDD drive... its is stupid but we never knows

I'm so sad man.. I can't play
 
Last edited:

Andrew_WOT

Premium
How about run without any monitoring software, no fps counters, nothing, current NVidia drivers still have issues in VR when GPU monitoring tools are used.
Also make sure that all CSP VR Tweaks and Custom VR mirror are disabled.
 
Last edited:

Mauser118

Premium
Are you running any monitoring applications? I've found running things that keep a track of frame rates cause a ot of stuttering, also disabling nvidia's crap gaming overlay can boost FPS by quite a few frames in VR, also disabling Windows 10's HAGS can help in get rid of stuttering.
 
How about run without any monitoring software, no fps counters, nothing, current NVidia drivers still have issues in VR when GPU monitoring tools are used.
Also make sure that all CSP VR Tweaks and Custom VR mirror are disabled.
I just turn on the afterburner and rivatuner for show how my GPU is with headroom.
even with these fps counters apps Off the problem remains.
Also, I did the test turning all CSP tweaks off. (also the mirror vr display)


Are you running any monitoring applications? I've found running things that keep a track of frame rates cause a ot of stuttering, also disabling nvidia's crap gaming overlay can boost FPS by quite a few frames in VR, also disabling Windows 10's HAGS can help in get rid of stuttering.
Thanks buddy, but I also did this test turning off and on the win10 GPU scheduling. It is off now..

So, I watched some youtube videos showing a software which calculate the latency of the system.
I'll give a try... and if it not solve, I'll one more time format the PC and install a fresh version of Win10

Thank you all guys.
If I have news, i'll report here
 
I spent hours reading tips you gave in other posts and other forums and sum all tips resulting this:

POSSIBLE FIX
(the culprit could be one or more of these steps)

- My 3080 was connected with PCI X4 speed. I changed the slots, now it is X16. (Thats because I have more GPUs connected on my mb)
- Rollback Nvidia Driver to version 461.40 I'm running the latest nvidia driver and its ok
- Make sure there is no app in background running (like Google Chrome etc)

.......

Comments:

- Even with Afterburner and RivaTuner running there is no stutterings.
- Even with Reshade and SharpenFX running, there is no stutterings. (I suggest everyone install this, absolutly visual game changer, I can help you to do this, PM me!)
- I have random stutterings (3 or 4 per track lap) only if NiceHash app is running (mining cryptos with my others gpus on backgroud) even with this, is completely playable.
- I read about some Windows update in January broke on few games the vsyinc causing random stutterings, and apparently they didn't fix this yet.
- I'm running with DRAM OC from CL16 3200 stock to 38ish CL18 but with considerable reduced latency tested with Aida64. From 58ms to 51. (Even with stock, there is no signal it is the culprit, 3200cl16 is alread great for gaming)
- Process Lasso and CPU priority HIGH on ACS.exe apparently has no effect.


Thanks everyone for tips.
You did the community great.
 
Last edited:

Peter Stefani

GT: Sneeb108/XBONE/us
Take ownership and Rename the Microsoft game bar Presence Writer, and then go through and change as many services to Manual instead of Automatic that you can. All that MS stuff going on in the background is what causes all those micro-stutters.
 
Top