Big problems with sky of 3rd party tracks

M

meclovin

Hello everybody,

I really love Racer, but since I upgraded to Windows 7 I have got problems with the skybox in every track except for Carlswood NT.

Here is a screenshot of the bug:
pic2.jpg

My system: Windows 7 Enterprise, Intel Core2Duo & nVidia 9800GT

It would be great, if you could help me with this problem, because it's really annoying :D!
 

Attachments

QuadCoreMax

500RPM
Hm, I can think what it might be, still don't have enough experience yet.

Did you check if there are actually in geom ini & also if they got correctly textured in shd file ?
From pictures, I see no skydome, so the normals should be reversed ?

The easiest, you take Carlswood skydome in your maps & finally tweak it as you like it.
 
M

meclovin

Thanks for the tip, I am not really experienced with racer!

I tried to replace the sky files with the ones from carlswood and I replaced the gfx part in the special.ini, but the same error appears.

What I forgot to mention is, that in the beginning of the race the sky is just black and then when I start driving you see this problem like in the screen above.

When I open the track in tracked everything looks alright.
tracked 2010-08-13 19-57-06-58.jpg

EDIT:
I think this is the problem, but I don't know how to solve it (
part of the log file)
Fri Aug 13 19:48:15 (INFO): --- application start ---
Fri Aug 13 19:48:15 (WARN): No shader found for material 'sky' in 'data/tracks/Grand_Valley_Speedway/sky.dof' (default '<no texture>')
Fri Aug 13 19:48:15 (WARN): No texture for geob 0 (geode sky.dof)
 

Stereo

3000RPM
You need to open track.shd and add in something like:
Code:
vf_sky
{
  vertex_shader
  {
    ;file=sky_daynight_v.cg
    file=sky_v.cg
  }
  fragment_shader
  {
    ;file=sky_daynight_f.cg
    file=sky_f.cg
  }
}

shader_sky~vf_sky
{
  sky=1
  cull=none
  layer0
  {
    map=sky_clouds.tga
    depthwrite=0
  }
  layer1
  {
    map=sky_night.tga
    depthwrite=0
  }
}
(this is from Carlswood)
Obviously need to change the texture names to match whatever the track has used (first layer is daytime, second layer is nighttime), and if the error is for material other than 'sky', change shader_sky to match shader_name.


Recent versions have been changing sky settings a fair amount, on most tracks you'll need to correct this kind of thing to get the sky to appear right.
 
Top Bottom