Arduino Leonardo wheel.

Discussion in 'Sim Racing Hardware' started by Sieben, Oct 31, 2018.

  1. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    [​IMG]
     
  2. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    Drill chunk with key is a connector to the steering column shaft.
    But put a base with direct connection to the wheel.
    Put a base on the rubber buffers. No noze)

    [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
     
  3. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    Just to show the ffb rotation rate)

     
    • Like Like x 1
  4. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    [​IMG]

    "Quick release", made simple.
     
  5. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    Please, I need an advice.
    Do you use external power supply For Omron CWZ6C (5V with pull up resistor-562 Ohms) or 5V from Leonardo?
    Very Thanks bro
     

    Attached Files:

  6. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    Yes, external (smth higher then 5V and up to 24V, You know) for it. With stm32 it goes with the board's 5 volts as is, if smth.
    What BTS do you have?. I mean those for 5USD is a mess. Need to have authentic ones.
     
  7. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    I have everything original Arduino. I will try to connect as shown with the external 5V and pull up Resistors 1K2 Ohms (or 562ohms). Then I change to 12V.
     

    Attached Files:

  8. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    You can also omit pull ups and power to "z". )
     
  9. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    Používáte Emc 0.9 od EbolzMagy? Potřebuji radu
     
  10. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    (Are you using Emc 0.9 from EbolzMagy? I need an advice)

    Yup.
     
  11. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    I set up everything in EMC, everything works,but ffb is bad. Testing with Wheelcheck does not work well. The steering wheel turns only on one side. I set emc and can not see any changes. I use pwm+-. With wheelconfig works great.
     
  12. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    You mean with step log test? Or with cycle test? Mine worked fine. It might depend from the motor with step log the motor respond in other direction. But ffb was fine. Can check the spring test? How it goes? There also should be 4x multiplier from encoders ppm amount chart in emc for encoder.
     
  13. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    Udělal jsem lineární test (viz video), ale můj volant neudělal nic a pak jen rychlou rotaci

    [MEDIA = youtube] HKVOqU1afVE [/ MEDIA]


    Mám omron 1000ppr. Vstoupil jsem 4000. To je to, co myslíš?
     
  14. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    I did a linear test (see video) but my steering wheel did nothing and then just a quick spin
    I have omron 1000ppr. I entered 4000. That's what you think?


    Encoder can have a&b mixed up by itself. Change connection if your rotations of a wheel in soft is opposite to the input on the wheel you do. Don't use invert graph. Change sides of the the PWM R/L cables with each other. Do in sequience. First wheel rotation side, then pwm.
    In ppr side all must be clear then.

    Also, center the wheel when it runs away each time while setting it up with that stuff. Or just rotate it backwards)
     
  15. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    Also be sure the wiring has all proper contact. That connectors are a funny thing.
    And with such amperage, 80amp like you do, watch over the bts. I burned down mines with 12.5amps. China copy is not a proper way to put it there. ) Common issue with'em.
     
  16. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    kodér má správné otáčení kola sEMC. Musel jsem přepínat kanály, ale to není problém. Dnes se pokouším vyměnit výstup PWM. Momentálně pracuji s maximem 34 A s 2 paralelními IBT-2.


    můžete mi ukázat nastavení EMC
     
  17. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    the encoder has the correct rotation of the sEMC. I had to switch channels, but that's not a problem. Today I'm trying to replace the PWM output. I am currently working with a maximum of 34 A with 2 parallel IBT-2.
    you can show me the EMC settings

    Ok. nothing special with'em. Later on, ok.
     
  18. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    I am currently working with a maximum of 34 A with 2 parallel IBT-2.

    China copy don't give a damn on it) Just for info.
    Even though. There normal operation in 10amps. The pick load is only for a short time. As per manual. With such motors, they can pump max almost always. So like that.
     
    • Like Like x 1
  19. Jan Pokorny

    Jan Pokorny

    Messages:
    10
    Ratings:
    +2
    Change sides of the the PWM R/L
    Do you mean PIN 10-11 on the Leonardo board?
     
  20. Sieben

    Sieben

    Messages:
    72
    Ratings:
    +30
    Yes.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.