Anyone Use a Logi G29 with rFactor?

newbert

500RPM
Premium
I'm having trouble controlling oversteer with my Logi G29 in rFactor. For example, even with a stable setup provided to me, at the sweeping left hander at classic Imola just after the S/F line (which one should be able to take at to speed, I can't sense early enough when the backend starts to lose grip - even though the grip loss comes on gradually.

I suspect that I need to adjust the Logi G29's settings in rF2. (I don't use the Logi software...). So would anyone be willing to share their G29 in-game settings? Or at least provide any thoughts on controlling that gradual oversteer?

Thanks!
 

AyrtonForever

100RPM
Premium
i think there's nothing to adjust in ffb settings, except car ffb multiplier, which i lowered to 0.70 more or less, to avoid clipping. more over with G29 you must make some changes in controller.json, in order to have correct steering range for every car, you can read how to do it here. before doing this in logitech software you have to create a profile for rf2, which point to rFactor2.exe in "Bin64" folder, and set max steering rotation to 900 degrees
 
Last edited:

AyrtonForever

100RPM
Premium
i ever felt very well oversteer in rf2, maybe most of the problem is you are using too high ffb multiplier, which involves clipping. which value you have for car you are talking about?
 

newbert

500RPM
Premium
i ever felt very well oversteer in rf2, maybe most of the problem is you are using too high ffb multiplier, which involves clipping. which value you have for car you are talking about?
FFB Multiplier is on 1.0 for the BMW2002. What setting would you recommend?
Thanks!
 

AyrtonForever

100RPM
Premium
never use 1.0 for any car. don't know this specific car, but try with 0.70 and eventually go up or down, but keep in mind that the more you go up the more you have clipping and loose feeling
 
I have been using a G29 for about 3yrs and I have a pretty good feeling with my wheel. You really need the Logitech software installed so you can set the steering wheel sensitivity to 50% any higher and you get over steer and any lower and you get under steer, 50% is the default, I think without it installed it defaults to 100%. Enable centering and set to 5-10%. In rf2, set steering rate to 1%, speed sensitivity to 0%, I usually find .85 in the multiplyer suits most cars, there are exceptions though. I set FFB smoothing to 20%, I prefer a smoother feel to the wheel otherwise it can feel a bit harsh and notchy. Vehicle set enabled. Minium ffb 14.5%. Hope this may of help to you.
 

Martin Fiala

5000RPM
Premium
never use 1.0 for any car
That's an advice that doesn't make much sense as a general recommendation, given how wide range of the FFB on individual cars is. I mean, on certain cars, you even have to go well above 1.0 to get full range of FFB.

The correct way to set the multiplier would obviously be to drive a few laps, check if you're clipping, do some appropriate adjustments if necessary, and then rinse and repeat until your FFB multiplier is set as it should be (so with more or less no clipping, but still as high as possible).
 

newbert

500RPM
Premium
That's an advice that doesn't make much sense as a general recommendation, given how wide range of the FFB on individual cars is. I mean, on certain cars, you even have to go well above 1.0 to get full range of FFB.

The correct way to set the multiplier would obviously be to drive a few laps, check if you're clipping, do some appropriate adjustments if necessary, and then rinse and repeat until your FFB multiplier is set as it should be (so with more or less no clipping, but still as high as possible).
This all makes sense, Martin - except how do you check for clipping in rF2? There's an app that does it in AC, but I don't know of how to do it in rF2.
 
Top Bottom