EU Alfa GTA vs Mito vs 500 @ Spa - Wednesday 12 August 2015

Akis

Over 9000
rd-500-spa.jpg

Small cars at a big track!

All premium members can sign up for this event and we have unlimited slots available so make sure to bring a friend. Sign up below and make sure to tag fellow community members who you think are up for a challenge!

Join us
Not a premium member yet but interested to race with our group of friendly drivers? Click here for more information and learn how you can participate as well. See you on track?!

Server Name: RaceDepartment.com #2
Server and Teamspeak Password: click here
Racing Club Rules
: click here
Cars
: Alfa Romeo GTA, Alfa Romeo Mito, Abarth 500 SS
Track: Spa (Green track)

Booking: no
Practice: 18:30 GMT (30 minutes)
Qualifying: 19:00 GMT (15 minutes)
Race: 19:15 GMT (10 laps)
 

Akis

Over 9000
Entry List
  1. Tommi Saari (500)
  2. quicksilver384 (Mito)
  3. Geof (GTA)
  4. Akis (Mito)
  5. Andre CZ (Mito)
  6. Tobias Röhner (500)
  7. Martin Faber (GTA)
  8. EireGreen™ (500)
  9. Christoph Wohlkönig (GTA)
  10. Dragos Haba
  11. Free spot
  12. Free spot
  13. Free spot
  14. Free spot
  15. Free spot
  16. Free spot
  17. Free spot
  18. Free spot
  19. Free spot
  20. Free spot
  21. Free spot
  22. Free spot
  23. Free spot
  24. Free spot
 
Last edited:

Akis

Over 9000
I'll be joining you with the Mito.
Thinking of adding some ballast to the 500 and the GTA to even out the laptimes.
 

quicksilver384

Roaring Pipes Maniacs | #85
Ok I have a slight problem. I upgraded to Windows 10 and since then my TS wont work and I cant get one to work.

If you will allow me to race without TS then great. Im going back to 7 when my new SSD arrives.
 

Akis

Over 9000
Ok I have a slight problem. I upgraded to Windows 10 and since then my TS wont work and I cant get one to work.

If you will allow me to race without TS then great. Im going back to 7 when my new SSD arrives.
TS is recommended, not mandatory, so you won't have any problem in racing ;)

On a side not I reverted back to Win 8.1 because of ping(!!?!) related issues with the Win10 installation.
 

quicksilver384

Roaring Pipes Maniacs | #85
Ok great thanks.
I will have to see how the ping is. Im on 68Mbps line so should be ok but if its too bad then feel free to kick me out of server :)
 

Herbie

500RPM
Yeah, was fun! I knew GTA was "wrong" choice for me but i like that sound too much :D
Was fun to drift a bit...not intentionally but who cares :laugh:

"Unfortunately" i am moving next week from flat to house and have to disassemble my rig:(
Hope i'll be back soon :thumbsup:
 
Top Bottom