AIWCAM Editor Problem, can't write files, "read only"

kmikiwi

25RPM
Hi everybody!...

Well, I'm using the AIWCAM Editor to correct the racing line to a track wich was made in 3dsmax, so we can't insert it into the BTB, everything works ok, but after changes when I click on save waypoints appear a message: "DID NOT SAVE, check file is not read only".... I check the track's files, donno have "read only" checked, the rfactor files has not checked it too...

I can't find why AIWCAM can't write the file and donno save changes... I run rfactor as administrator but it doesn't works!

I use Win7 Ultimate, rfactor 1225, rfactor game is installed on a different partition, not in system C.

Thanks!
 
A

amoraes

Just to check, do you have the DEVFILES folder in rFactor root folder? Did you try with other tracks to check the result? I guess it wouldn't even read without the DEVFILES but I couldn't think of anything else. The other possibility would be if rFactor were installed in the Program Files folder but you ruled that out.
 

kmikiwi

25RPM
Yes, I've the DEVFILES into the correct folder, I tried with 4 different tracks. it's a odd problem! :(
 

FerrariMan96

1000RPM
I had this problem once.

You know how Brendon says to run BTB in administrator mode?

Well, thats because otherwise you will not be able to save your projects because your PC won't let you touch the C drive (or wherever your Program files are).

It's the same thing with ISI's AIWCAM editor. you have two options:

  1. Run rfactor (or specifically rfactor AIWCAM) in administrator mode.
  2. Go to your rfactor root folder then go to GameData\Locations\<<YOURVENUE>>\<<YOURTRACK>> and find your AIW File (or CAM file if you're editing the cameras). Right click on it then Left click on Properties. Go to the security tab then click on the button that says EDIT. In the new window that pops up click on your User in the top box then in the bottom box make sure the boxes Edit, Read & Execute, Read and Write are all ticked (There are four in that list). I have Vista - whatever you have may be slightly different:biggrin:

Both of these options allow rfactor to edit the AIW File (or the CAM file if that's what you're editing). The First is easier BUT WHEN RUNNING IN ADMINISTRATOR MODE YOU CANNOT ACCES YOUR NORMAL PROFILES. Hence I use method two.

Hope this helps:wink:

FerrariMan96
 

kmikiwi

25RPM
Hey! thanks, I tried everything u told me... but, nothing works! ... I feel I'm loosing this battle... :frown:
 

kmikiwi

25RPM
I made a lot of copies when I tried to use the temp.aiw file that AIWCAM Editor creates and doesn't work... I made what u said about resave file with the CAM Editor, but it's the same problem: "DID NOT SAVE, check file is not read only" .... Will we die??? :pcbeat:
 

RT1971

75RPM
Check your permissions for your Rfactor folders, also run the editor in Admin mode, just noticed you were using 7.
 

doser

25RPM
Definately sounds like a User Account Control thing, "Run As Administrator..." etc.

It would only say read-only if the AIW was set to read only, or your user account didn't have permission to write files.
 
Hi kmikiwi,

I had the same problem. I found that if you remove all of your plugins from the plugins folder it will allow you to save it.

I do not know which plugin was causing the problem so I removed them all while editing waypoints and then replaced them when I had finished.

Hope this helps,

Dan
 
Top Bottom